View Full Version : cordless keyboard problem

07-07-2003, 04:37 AM
Hi to all

I recently bought a
Logitech Cordless Navigator with optical mouse.

I installed on my Dual Xeon (SuperMicro MB) on PS/2

After I installed the software iTouch v 2.15 and all
softwares work well

BUT in VT [2]

there is some conflict that you cannot use the software
i.e. you cannot type in File properties and all key don't work well.

Do you know if there is some conflict with drivers of Logitech?
What can I do?

Help please!


07-07-2003, 05:26 AM
One of Logitech's reccomendations is to make sure your cordless 'sensor' (I foreget how they refer to it, but the thing that plugs into the computer ports) is at least 8 inches away from your monitor. I have found this makes a difference :)

07-07-2003, 07:34 AM
Thanks for suggestion
I already knew that. In fact with ALL other applications all
is good, only inside VT there are problems: I think there is some
driver conflict.

07-07-2003, 11:29 AM
Just to update...

I tried to substitute the Logitech driver
with a generic Microsoft 102 keyboard
from Control Panel->Keyboard

Now it works!

But I don't have anymore the
functionality of the dedicated keyes.
They are useful to use as shortcuts...

This confirms that is a driver conflict.
It is strange that there is a similar problem.
Anyone there have this problem with Logitech
iTouch driver?

Any ideas to solve this?


07-07-2003, 11:39 AM

I've been using the Logitech cordless (non-optical) mouse/keyboard combo for a couple of years now without any problems at all with the Toaster.

mouse - v9.11.0.0
keyboard - v1.50.0.0

07-07-2003, 02:17 PM
Have you ever installed iTouch driver?

I tried with v2.10 & v2.15 They are the same.
The mouse works well.

From Logitech site, it seems to be only this
support driver for keyboard, also for older models
(I have another keyboard-mouse combo without extra keys
and I found out to download the same iTouch driver).

So, if I want the extra key to function
(and also to have the value for battery charge),
I cannot use the Toaster!

If I use the Toaster, I have not this features...


07-07-2003, 07:43 PM
Yes, I do have iTouch running.

07-08-2003, 10:07 AM
I have tried to use the USB connection instead of the PS/2. Now it works well, with the same iTouch driver v2.15.

Now the Toaster works and the keyboard has full functionality. Why doesn't work in PS/2?

BTW, these latest cordless keyboards from Logitech (I tried also the more expensive ones) aren't good in the plastic construction. They seems very fragile and the keys pressed give terrible sensation...


07-08-2003, 12:59 PM
I have used the wireless logitech keybored with the PS/2 version. It worked fine, but I haven't used it with the latest builds.

Blaine Holm
07-11-2003, 04:10 AM
The i touch software causes a conflict in VT2, preventing you from typing in filenames when saving. I'll try it to see if VT3 works.

07-11-2003, 11:25 AM
Originally posted by Blaine Holm
The i touch software causes a conflict in VT2, preventing you from typing in filenames when saving. I'll try it to see if VT3 works.


We're running the Itouch software here and have never seen a conflict with VT2. Could the conflict be stemming from running it under WindowsXP? Our VT2 system runs Win2k.



Blaine Holm
07-11-2003, 11:34 AM
what version?

it does it on win2k and winxp

07-11-2003, 06:43 PM
Ahhh - let's see,

Win2K SP3

T2 - build 3890

not sure how to tell what version of Itouch,
but when looking at mouse properties,
I come up with:
Control Center v9.12.73
Mouse driver v9.11

In device mgr,
Keyboard driver ver 1.50.00

I know that the drivers haven't been updated for a while,
so please don't tell me that I should update them . . . otherwise I may end up in the same boat!

as the saying goes "if it works, don't mess with it"