PDA

View Full Version : Light intensity descrepencies in Layout



Hopper
12-02-2007, 10:15 PM
Hi guys,

I was curious to know if I'm simply doing something horribly wrong or it's just another "feature" of Layout...

Scene:
Small set of basic geometry (Cube, 2 cylinders, etc...)
Luxigon lighting setup with 75 distant lights all with intensity of "4".

I renders fine with all the correct lighting, etc... but in "Camera View" I can barely see anything - like someone turned my lights out!

Is there an interface intensity of some sort that won't affect my actual lighting? It's fairly annoying to crank up the intensity, then remember to turn it back down for renders.

Thanks

Hopper
12-02-2007, 10:20 PM
..and as a reference, here are two images - one render and the other is the camera view.

Maxx
12-03-2007, 06:20 AM
OGL in Layout only displays 8 lights tops, so really you're only seeing 32% of the lighting in your scene. And that's spread across 8 different lights pointing 8 different directions.

What I tend to do in similar situations is to add an additional light called simply "OGL", turn off the eye icon in the scene editor (making the light into a LW "work light" - no render effects at all, but OGL works) and turning off "Affect Open GL" in the properties panel or the scene editor for the remainder of the lights. This lets you crank the work light to accommodate acceptable levels for working in Layout but not tweak out a render at all. And no annoying resetting light intensities.

Hopper
12-03-2007, 09:07 AM
Ok .. now I'm just embarassed. I'm such a dork. I knew that. What the hell was I thinking. It's not like you don't see the "Max OpenGL Lights" box everytime you open the OGL display properties.

Well.. the only thing I have as an excuse is that this was the first time I have actually used more than 8 lights (i.e. luxigon, etc..). And yes, I'm that much of a newbie. Animating and rendering is cool, but my preference is to model. I'm into the clay look. :)

However, I have noticed that you DO sometimes get a big difference in lighting intensity from the view to the render (especially using distant lights with no falloff). My scene will look totally washed out in the camera view and render fine.

And thanks for the lighting tip Maxx, I will definately use that idea.

Maxx
12-03-2007, 11:35 AM
Happens to the best of us - I actually spent over an hour recently trying to figure out why I wasn't getting any contact shadows before I realized I'd forgotten to turn on Raytrace Shadows in the render options. I wouldn't call myself a pro, but I've been using LW since version 5.5. And this was recently, as in a couple weeks ago... :screwy:

So don't feel bad. And yes, you do sometimes get some rather large discrepancies between OpenGL and render lighting.

Giacomo99
12-03-2007, 01:01 PM
FYI: To get the overcast look you seem to be going for-- instead of using a whole mess o' Luxigons, you could turn on "Background Radiosity."

In my humble experience, it's seldom necessary to use more than two lights in a scene. Really.

Hopper
12-03-2007, 04:15 PM
FYI: To get the overcast look you seem to be going for-- instead of using a whole mess o' Luxigons, you could turn on "Background Radiosity."

In my humble experience, it's seldom necessary to use more than two lights in a scene. Really.
Thanks for the tip! I'll give that a try also. For the example I had (which caused my issue to begin with), I was just tinkering with one of Proton's video toturials on the "Spinning Light" trick etc. I too usually use 2 lights normally.