PDA

View Full Version : Outline render using imported geometry



spacekadet
11-21-2007, 05:09 PM
Hi,

I'm trying to get a workable process to import lots of SolidWorks files into LW 9.2 so I can render them as outline drawings for use in manuals.

I'm using the demo version of NuGraf / Polytrans (demo version) to convert the file format. This parts works very sweetly.

The problem I have is that the silhouette edge render option in LW produces nothing. The other two options (Unshared and Sharp Creases) both produce lines in the render, if I enable them.

The silhouette option is of course the main one that I need for outline drawings. It's really a pity - so close, yet so far!

Does this seem likely to be a case of incorrect settings or some other user error in LW? Could the imported geometry have some kind of defect that causes this?

cheers...

MooseDog
11-21-2007, 05:21 PM
what lw version are you using?

if it's 9.3, make sure in the render globals dialogue box that the render lines box is checked. if it's pre 9.3, only classic camera could render lines.

spacekadet
11-21-2007, 09:21 PM
what lw version are you using?

if it's 9.3, make sure in the render globals dialogue box that the render lines box is checked. if it's pre 9.3, only classic camera could render lines.

Hey MooseDog,

Thanks for reply. I am using LW9.2

The camera is "classic" camera (actually it is the default camera). Are there any other settings I need to check?

Exception
11-22-2007, 10:06 PM
Hi Spacekadet,

Welcome to a very powerful feature of lightwave, and to our community. I love using the outline render tools.

Certain things to keep in mind:
Lightwave discerns between the different line types by means of the smoothing angle of its surfaces. So, sharp edges only occur where the surface smoothing angle is beyond that which is set in the surface.

In your particular case there are several things that could be the cause.

1) the model itself is at fault

Open the object in modeler, merge all points (m key on the keyboard), and check for 2 and 1 point polygons using the statistics panel in polygon selection mode, and delete them if present.

2) the surfacing of the model is at fault

make sure smoothing is turned on for all surfaces. throttle back the smoothing angle to the desired setting. I usually find 60 degrees to be a nice general setting. you can mass-edit all the surfaces by shift-selecting the first and then the last, in case you have many surfaces.

3) your settings may be at fault

The classic camera uses different kinds of line rendering methods than the perspective camera, but only since version 9.3 can the perspective camera render lines. So stick with classic camera for now.

If this does not resolve your problem it'd be helpful if you could post the scene and the objects. We could then check the scene for you and see what exactly is going on.
rest assured, we can solve this issue.

Cheers and happy thanksgiving,

Exception
11-22-2007, 10:16 PM
PS

Upgrading to lightwave 9.3.1 is free and sincerely recommended.

gristle
11-23-2007, 02:42 AM
Hi,

I'm trying to get a workable process to import lots of SolidWorks files into LW 9.2 so I can render them as outline drawings for use in manuals....

Could you not generate the line drawings in Solidworks? Depending on what type of output you want it might be better.