PDA

View Full Version : Object Replacement not working



carrot999
11-20-2007, 06:42 PM
Hi there,

I have been trying to get Object replacement working without success.
I have created 2 objects: ball000.obj (a cube) and ball010.obj (a sphere).
I create a scene with ball000.obj as the only object.

a) In the object properties - Object Replacement, I try to select Object Sequencer but nothing happens. The Object Replacement button still reads (none), Options button remains greyed out, and my cube is not replaced with the sphere at frame 10.

b) I created a text file (ObjRepl.txt) with the following:
____________________________________
#LW Object Replacement List
0
E:\LIGHTWAVE\LW_Projects\Test\Objects\ball000.obj
10
E:\LIGHTWAVE\LW_Projects\Test\Objects\ball010.obj
____________________________________
I set the Object Replacement to Object List, click Options and select this text file. Still my object is not replaced.

Am I missing something here? Any assistance would be gratefully received!

Cheers, Lisa
P.S. I am using LW9 build 998 (Win32) on a PC running XP Pro

BeeVee
11-21-2007, 03:31 AM
If the paths are right, then it should work fine - have you tried rendering out a sequence or preview? Object sequences often don't get updated in OpenGL always.

B
PS. You could (and should) be using build 1291 since LightWave 9.3.1 was posted to your account last night.

carrot999
11-21-2007, 11:24 AM
Thanks B,

What do you mean about paths? My object is static.
And yes, i have rendered out previews before and after the frame where the replacement should have taken place.
My scene with the ball/box is just a test one, my real scene contains some scenery (trees etc) that I want to replace with low poly objects after a certain frame number to help speed up rendering.

Also, sorry to sound like a complete idiot, what did you mean about 9.3.1 being sent to my account? Is there somewhere I can download upgrades?

Many thanks,
Lisa

carrot999
11-21-2007, 12:07 PM
Aha, I see you mean Content Directory Paths,
Yes, my paths are correct but the object replacement is still not working.
Any other ideas?

Cheers, Lisa

markschum
11-21-2007, 12:18 PM
Under customer care > registration you can find the update downloads

carrot999
11-21-2007, 03:34 PM
Wow! Thanks for that info. I have now downloaded and installed the latest and greatest, and guess what!? Object Sequencer now works!
I still cant get the Object List to work tho...hmmmm. No matter, at least I can now acheive what I need to using the Sequencer.

Many thanks for your help and advice Ben and Mark.

Cheers, Lisa:thumbsup: