PDA

View Full Version : LW not rendering alpha channel



drclare
11-02-2007, 03:36 PM
I had a scene with a "Render Buffer Export" plugin enabled to render out a depth map. When I disabled the plugin I notice LW no longer rendered an alpha channel. I enabled the plugin again and the alpha channel came back. I accidently deleted the plugin and now no matter what I do I cannot get LW to render an alpha channel. After some experimenting I also notice that the backround is acting funny. I have an Image World background. If I disable that and render with just the background color it will only render with a black background, no matter what the background color is set to. If I enable gradient background, still just black, and of course still no alpha channel. I can enable the textured background plugin and it will render, but still no alpha. I imported the scene into a new scene and got the same problems. But I imported just the models and camera into a new scene (no lights or plugins) and the alpha channel worked normally. Any idea what's going on? Thank you for any suggestions.

iconoclasty
11-03-2007, 10:16 AM
Have you tried starting a new scene from scratch and tested the alpha?

drclare
11-03-2007, 11:17 AM
Yes I did and it rendered fine. So I have fixed it now. I think the reason it didn't work before was because when I imported the items from the old scene into the new I also imported the plugins, and it turns out that for whatever reason it was the image world plugin that wasn't working. So I created a new scene and imported only the objects, lights, and camera and it worked fine. I did have to delete and reload the image world plugin though.