PDA

View Full Version : quicktime bright bug



JML
10-31-2007, 07:02 AM
here is the still that shows the problem,

when we compile tga frames into a quicktime file, the render becomes a lot
brighter than it was.
I'm trying to find out what setting to use for it doesn't alter my renders.

the animations was compile with aftereffects, on a pc and on a mac, and the same over-brightness problem happened.

any ideas ?

thanks

JML
10-31-2007, 07:11 AM
it happens with different codecs, (h264, 8bit uncompress, mpeg4,etc..)

Boris Goreta
10-31-2007, 08:14 AM
This is normal because Mac uses different Gamma. Windoes uses 2.2 I think and Mac 1.8. To override this go to Edit-Preferences-Quicktime Preferences-Advanced and select Safe Mode Video (GDI only). Then quicktime will show correct colors.

Sarford
10-31-2007, 08:16 AM
hmmm, The gamma on a mac is generaly lighter (1.8) than on a pc (2.2). That means that images made on a pc will look lighter on a mac and vice versa. Other that that, I have no idea.

edit: hehe, bgoreta1 was just 2 minutes faster :D

JML
10-31-2007, 10:08 AM
I can see the difference on a mac too,

on a mac, the render also looks different that the quicktime output.

toby
10-31-2007, 02:39 PM
Check AE's colorspace setting for the project.

And you can open a tga frame in Qt and see what it looks like, to check Qt.

JML
10-31-2007, 05:06 PM
thanks toby, I'll try that.

Mr Maze
10-31-2007, 05:55 PM
Are you using H.264 to compress? If you are, it will affect contrast/sat/brightness.

I do have a trick for H.264 to help with this (from a PC workflow where most video is edited in Premiere Pro and output to AVI, then taken into QT and exporting .mov using H.264).

Once you have your finished compressed video:
Go to Window>Show Movie Properties
Click on Visual Settings Tab
Change transparency to Blend, and move slider to 100%
Close Movie Properties
Save File

After you save, hit play, and it will look better. The whole safe-mode thing sucks on Windows it can affect playback on slower machines (I don't know who your intended user base is). bgoreta is partially right - it is a combination of compression and Apple software thinking it knows more than you do about color profiles/gamma. Other Apple software does the same thing (especially iLife).

JML
11-01-2007, 06:59 AM
I changed the AE to the right profile, and after compiling the mov,
it was the same, too bright.

if I open the TGA directly inside quicktime, they look good.

if I compile the animation without any compression, so lossless, brightness is good

so it's H264 that is making everything brighter.

so knowing that, I changed the brightness of my anims in AE, -20 brightness,
and compiled it with H264 and now it looks good :)

thanks everybody

JML
11-01-2007, 07:48 AM
nevermind,

quicktime display the animation fine on another mac,
the difference was the OS color profile.

so it seems that quicktime doesn't like any other color profile other than appleRGB. (when outputing H264,8bituncompress from AE)

so after changing the mac to appleRGB, the quicktime looks a lot better,
but looks overbright on windows machine or mac that uses a different color profile. ..

those quicktime are meant for a presentation in keynote, so on a mac, so it should be fine.




bgoreta is partially right - it is a combination of compression and Apple software thinking it knows more than you do about color profiles/gamma.
I confirm !

evolross
01-13-2008, 11:30 PM
This is normal because Mac uses different Gamma. Windoes uses 2.2 I think and Mac 1.8. To override this go to Edit-Preferences-Quicktime Preferences-Advanced and select Safe Mode Video (GDI only). Then quicktime will show correct colors.

Had the same problem. And this fixed it. Hopefully my customers will do the same because it looked totally different. Funny thing though, it happened with a Windows Media Video file in Window Media Player too. But the above did fix my Quicktime in Windows. :)

evolross
01-14-2008, 12:12 PM
I was doing more testing and the brightness - coloration - gamma issue only occurs on the 64-bit machine you generate it on! I run XP x64 and when I encode any video (Quicktime or WMV) in Premiere CS3 it appears much lighter than it should.

However, I can send the same video to any number of 32-bit machines and it looks perfect (at least the Quicktime does - I didn't test the WMV).

So this seems to be a feature of 64-bit OS's. I spent two hours trying to rebalance my color in Adobe Premiere only to suddenly think - wait! - I should test the video on another machine. :bangwall:

With that said, the above mentioned Quicktime settings trick will allow the video to look correct on your 64-bit machine.

Anyone know of an equivalent setting in Windows Media Player? As WMVs are coming out bright in XP x64 too (from Premiere's Adobe Media Encoder). I assume they'll look fine when viewed on a 32-bit machine.

Exception
01-14-2008, 02:26 PM
It's a bug in H264 in quicktime.
They're saying they're working on it but it's taking quite a while!