View Full Version : New guy asks: subpatch me, please!

10-31-2007, 12:12 AM
Hi all,
I'm new here. Just got my dongle two days ago after a week with a "discovery mode" version of v9.0. Using 9.2 as 9.3 doesn't see my product key, but I'm not worried about that yet as I see a lot of you all have had issues with 9.3 anyway.

I've been loving it, exploring tools in modeler to create some simplistic architectural designs and abstract structures.

Now playing with displacement maps in Layout to create a nice landscape for my buildings, and after figuring out that you should start small like they do in the tutorials, I'm now stuck with something else (which is why I am finally making my first posting!)

Layout is applying the displacement maps to the object polygons, but it's not creating the subpatch mesh. What am I doing wrong? Can't see anything I've missed in the manuals, tutorials or online.

Attached is a screen grab showing how I've made two displacement maps - one in Texture Editor, and the other in Nodes ... both are affecting the polygons.

One other thing: seems like Nodes are far more powerful than the layer system. Is it best to stick to them when possible?

Thanks in advance!


10-31-2007, 12:22 AM
One other thing. On the "Deform" tab, I have "Enable Bump" checked, with distance set at 1mm (the whole plane is 500mm square). All are set to "Before Local Displacement".

And as you can see in the image, "Display Subpatch Level" is set to 30.

Hope this helps you help me!


10-31-2007, 12:51 AM
You have to make sure that subpatches were applied to your mesh in modeler first. You also need to make sure you have standard subpatches or CC subpatches selected because each subpatches to different amounts of polys for the same subpatch level.
Nodes can be more powerful but can also take longer to wrap your head around and setup. I find myself going back to layers to get things done quickly in production work.

10-31-2007, 02:48 AM
Thanks for the quick response, Larry.

I had Subpatch Divisions set to 4 and CC Level set to 3 - the defaults, I think.

What do you mean by "selecting" them? In Modeler? Other than setting the general options (as above), I don't see any mention of subpatches in Modeler. Even in the manual for Modeler, the only mention seems to be "Patch Divisions" which points to the bit on the general options menu.

I'm guessing there is some box I'm not clicking. What am I missing?

10-31-2007, 02:57 AM
Select the terrain in modeler (make sure there are no 5pt+ polys) and hit tab.
5pt+ polys are possible in subDs, but require CA Clark and are slower.

Did you see the looong but most likely helpful tute on making mountains (http://www.newtek.com/forums/showthread.php?t=42754)

There is also an option within Layout (in the modeling window I believe) to change the subd settings of an object.

Bon chance!


10-31-2007, 02:59 AM
What a second - I got it ... or at least I got the result I wanted.

Under the Construct tab in modeler, I hit Convert>Subpatch with the plane selected, saved and synced with Layout, and it works ...

I need to watch them again, but in the two video tutorials I watched on displacement maps, I don't recall either showing this. Is this normal? What's the standard practice? In the videos this seemed automatic ...


10-31-2007, 03:02 AM
Awesome, thanks! Yes, I watched that video. It was inspiring! I'll have to go watch again and see if said anything about hitting the tab key.

Okay, this was holding me up in a big way. Now to dive back in!


10-31-2007, 03:03 AM
It is 'normal' in the sense that LW needs you to choose whether you want it smooth or not .. for some surfaces, such as rock, a high subdivision surface without smoothing will be required.

In the tute I posted, he does turn on subpatch as far as I recall .. TAB key is your friend.


10-31-2007, 07:25 AM
If you haven't found it already... this page


has many video tutorials that cover all different topics. Including displacement, APS, nodes, etc... Worth a look.

10-31-2007, 08:44 AM
Thanks. Downloaded and watched many of them - not that I could put it all into practice yet.

I do now have another problem:

Trying to get the color gradient applied as the color of the landscape object. Looks like it renders on the previews in Node editor, but not in the viewports. See attached.

Obviously, I want the white in the mountain tops, and green below. (How would I scale this to the correct heights on the Y-axis anyway?)

I'm sure it's another simple thing I'm missing here ... can someone tell me?


10-31-2007, 10:20 AM
Hilarious. Typical of my experience with LightWave over the last week or so, I must have clicked, or unclicked, something to get the color applied in a render. I unclicked radiosity in the render options. Was that it?

But the color gradient surface is not visible on the object in the view ports. Should it be? It's just a simple gradient on a big, subpatched plane for a landscape.

Here's where I am (attached) ... now, to sort out the color heights!

10-31-2007, 10:27 AM
No it won't be, but it looks like you have it, just need to switch around the gradient or adjust the keys...


10-31-2007, 12:11 PM
Thanks, Ben.
That image was using slope as the input, but I've been spending the time since then trying to get the input on the Y axis (it works with the displacement map, no?).

Seems like whatever I do, only the start or end color ends up in the render (I can invert to toggle!). What am I doing wrong? I thought it was a scaling issue, and that the colors were to far apart, so I tried narrowing down the scale (to .0125!), but to no avail. (See attached).

Can anyone tell me what I may be doing wrong?