PDA

View Full Version : Dual LWCAD Installation :



pumeco
10-19-2007, 09:50 AM
DUAL LWCAD INSTALLATION :
Although I have done this repeatedly now without problems, by following this advice you agree to take responsibility for your actions, and you agree not to hold me responsible for any result.

Those that followed a recent thread here will understand the reason for this thread, but to cut it short, I needed to run versions 1.5 and 2.5 of LWCAD on the same installation. Depending on how you use LWCAD, and what other tools you use with it, there could be various reasons you might need to run version 1.5 with 2.5. Whatever the reason, the need is caused by the fact that 1.5 curves are Catmull-ROM based, and 2.5 curves are NURBS based.

Uninstall your current LWCAD (1.5 or 2.5) using the installation utility.
-
Install LWCAD 1.5
-
Make a backup of the version 2.5 installation files as supplied to you by W-Tools.
-
On the backup, go into the CFGfiles folder and open the menu.cfg file in a text editor.
-
Change the line 'MenuEntry 1 LWCAD' to 'MenuEntry 1 LWCAD2'
-
Change the line 'MenuEntry 1 LWCADext' to 'MenuEntry 1 LWCAD2ext'
-
Save changes to the file.
-
Install LWCAD 2.5 using your edited backup.
-
Use the menu editor in Modeler to change the tab names to; LWCAD2 and LWCAD2ext.
-
Use the menu editor in Modeler to manually add two more tabbs called; LWCAD and LWCADext
-
Your menu editor will list both 1.5 and 2.5 tools. Now you must manually drag the 1.5 tools into your empty LWCAD and LWCADext tabbs.
-
You should now have a dual installation and be able to work with both Catmull-ROM and NURBS curves with LWCAD.


So there you have it, I hope it will be of use.
Yes, you'll have your Curve Knife back again, and yes, you can work with EasySpline much better with the Catmull-ROM curve of 1.5 :)