PDA

View Full Version : Vertex Baking bug



tfoster
06-30-2003, 12:00 PM
I have been having a problem for a while now concerning vertex baked geometry. I will sometimes bake an object(to vertex colors), and then set the baked object to display the vertex color map. Everything appears fine in the open GL window, I can see that the object is shaded correctly, all is fine and dandy. The problem is in exporting the object to our game engine and/or to another package. The vertex colors all appear as full bright (white). Checking the vertex info through the stats window in lightwave shows NO information for vertex colors. Now the weird thing is that I have found a work around. By unwelding all the points, and then re-welding, the vertex colors become numerically visible in the stats window. Note this doesnt change the actual look of the object in the open GL window. Exporting after this works fine. Has anyone else run into this? If so, why does baking sometimes work and sometimes not. It become a real pain when I export 50 objects, and dont find out the the vert colors are missing until I actuall see the object in our game engine. Any info would be appreciated.
By the way I am on 7.5B. I dont suppose C fixed this?

One thing I forgot to mention. In these cases, the vertex also do not show up in V-paint. Once again, unwelding/rewelding fixes the issue. My thought is that maybe the Vertex Color Maps are stored as separate files, and arent actually assigned to individual points (its a look up tabel basically). Somehow, the unwelding forces the actual points to accept vertex colors.