PDA

View Full Version : Modeler Numeric Panel Rotation bug? (all versions)



Chrusion
10-10-2007, 06:43 AM
OK, this thing has been bugging me like forever in Modeler and it seems it's been this way ever since there's been a numeric panel.

Do this...

Select an object (points or polys, doesn't matter)
Pick Rotate tool
Mouse drag rotate the object any amount in any view port.
Drop the tool
Undo the rotation
Pick Rotate tool again
Open Numeric Panel (it has remembered the previous rotation angle, center, and axis)
Click the Apply button
What happens?
Yep... Rotation occurs in the "negative" direction!!

WHY?

Modeler must be flipping the rotation axis 180 deg internally or something. Does NT need to fix this?

.

Sande
10-10-2007, 06:51 AM
Mouse drag rotate the object any amount in any view port.
Not in any viewport. That does happen when you for example rotate using mouse from top viewport - but if you are using bottom viewport mode it works correctly. It also works if you have first rotated the object without mouse using numeric panel.
That is one of LightWave's "undocumented features" I guess... ;) I'm nowadays so used to it, that I don't even notice it.

iconoclasty
10-10-2007, 09:09 AM
How the #$% haven't I noticed that before!
Sande's right though. Top viewport does it, but not Bottom. Front Does, back does not. Right does, Left does not. I can kind of see why, but that is strange.

Surrealist.
10-10-2007, 12:45 PM
I have noticed this but had not made note of which windows. Thanks for testing it. :)

That makes sense now because simply there is only one negative direction and one positive direction. It is not a bug. There is no reason that the negative and positive would change from viewport to viewport; certainly not any more than (-) or (+) on the X would be any different in the front or back view in so far as the numeric requester is concerned.

Chrusion
10-10-2007, 09:39 PM
AH! So it IS an axis "look direction" or "polarity" issue and numeric is basically missing this vital piece of information!

Then wouldn't it be advisable to have the numeric panel remember this key property when it remembers the other values so that when it is reinvoked, the rotation is repeated on the same axis "polarity" so you get the exact same results as with the mouse? Well, of course! Did I just sense Chuck whispering to the dev team to "make it so?" hehe

I bet this affects all the other tools that work on this 'axis look direction/polarity'. Hmmm...

.

VoltisArt
07-05-2008, 12:08 AM
Would be more sensible for all the numeric inputs to be absolute instead of relative. Let the mouse work exactly like it needs to, but show the numbers relative to the universal origin, not the viewport. This wouldn't change anything as far as starting off with numeric input...it would only change the numbers displayed when dragging with the mouse in those "backwards" viewports.

Hint hint, v10 dev team. ;)

KevinL
07-06-2008, 07:36 PM
Hint, hint v9.5 dev. team :)

zardoz
07-07-2008, 02:52 AM
yep I've noticed that since ever...ah well, it's one of those things that after a while you get used to...but it should be corrected.

3DGFXStudios
07-07-2008, 03:21 AM
I didn't notice this until you mentioned it. Funny. I've been using lightwave since version 5.4 on the amiga (I was 8 back then(or something close))

Surrealist.
07-07-2008, 03:26 AM
Yeah, it is just a display issue in the Numeric panel that is consistent with the mouse movement rather than the origin. Never really bothered me too much.