PDA

View Full Version : Texture antialiasing!



sean hargreaves
10-04-2007, 05:35 PM
Can someone please tell me where the Texture Antialiasing button is? And Newtek, why is it not next to Antialiasing in the Camera Properties panel?

Ugh!

Andyjaggy
10-04-2007, 05:45 PM
? there isn't an individual texture antialiasing button. ?

What are you up to these days?

Surrealist.
10-04-2007, 05:55 PM
In the Texture Editor hidden in the Mipmap Mode: Softness or Antialiasing.

sean hargreaves
10-04-2007, 05:58 PM
Hi Andy,

There is'nt? Well there should be!

As far as what am I doing.........

Getting annoyed at trying to balance my FPrime settings so I can get nice smooth edges on surved surfaces. I'm rendering a 4000 x 2000 image, it took 22 hours on Endlessly Refine. I have 3 area lights, not bright. I had my light quality settings at 0.5.
But, you know when you look at a rendering on a computer screen, and even though it is antialiased (mine was Extreme Antialiased) you see little jagged edges, then you zoom in a click and its smoother, then another click and its jagged again? Its like, what the hell, I have no yardstick on whether its antialiased enough or not. I mean, its a friggin large image. Am I not rendering long enough, or are my FPrime settings off?
I'm thinking of doing a 2000 x 1000 image, kicking up the lighting quality, and then seeing if that works.

Damn you pixels, every single one of you. And you, and you too, and yes you in the corner...........

sean hargreaves
10-04-2007, 05:59 PM
Wait, Richa....I mean, Surrealist.
Mipmap...what?

Wheres that? Please guide me gently, step by step.

Thanks!

Castius
10-04-2007, 06:02 PM
Zooming in on an images will only look good on multiples of the resolution. Like 25%,50%,100%,200%.

Surrealist.
10-04-2007, 06:03 PM
Open the Image Editor and make sure your image is the one selected then look for Mipmap Mode pull down center of panel.

Andyjaggy
10-04-2007, 06:04 PM
Yes as surrealistic said there is a setting in the texture editor that control how LW treats the images but overall you just have your AA setting that AA everything.

It sound to me like it is more a viewing problem. Check to see if you are viewing your image at 100%, because I know in Photoshop when you view your image at an odd percentage say 43.8% then you will get jaggies and not everything will be smooth. If you need it to look smooth at a certain size then you need to rescale the image to that size.

Now if you are looking at it at 100% and you still have jaggies then it is your AA settings. A word of warning with f-prime. I find with some images it is near impossible to get rid of all the jaggies. F-prime gives you very good renders very quickly but to get to that final refined stage takes forever. Sometimes it is faster to use native LW rendering. That's just my humble opinion.

Andyjaggy
10-04-2007, 06:05 PM
Zooming in on an images will only look good on multiples of the resolution. Like 25%,50%,100%,200%.

ya beat me to it :D

sean hargreaves
10-04-2007, 06:06 PM
I went into Texture Editor and found Mipmap quality and Mipmap strength.

The quality is High
The strength is 1.0

I dont understand any of it. Is this where you were mentioning Surrealist?

sean hargreaves
10-04-2007, 06:09 PM
OK Surrealist, did that, but everything is grey and cannot be picked. Why is that? Is it because I already have Antialiasing chosen in my camera property settings?

sean hargreaves
10-04-2007, 06:12 PM
OK, believe it or not, I'm actually figuring it out myself :D

BUT..........

The texture is a bump texture and its a LW native texture, Turbulence. I can't choose that in the mipmap window.

Is there yet, something else I am missing?

Andyjaggy
10-04-2007, 06:16 PM
mimaps only deal with images not procedurals.

sean hargreaves
10-04-2007, 06:35 PM
Thanks guys, I'll see how it does smaller yet with a higher lighting quality.

Hey Andy, hows Jerusalem coming? Are you almost done yet?

Andyjaggy
10-04-2007, 06:56 PM
Jerusalem is on hold at the moment, the client would never get back to use with exactly what they wanted so I'm just working on some other stuff at the moment.

sean hargreaves
10-04-2007, 07:03 PM
That really sucks, starting something and then being left in limbo!!

Andyjaggy
10-04-2007, 07:26 PM
yeah. unfortunately it happens more often then not.

RedBull
10-05-2007, 03:01 AM
Seems like the feature has been removed, because i swear i used to run into a problem where i needed most maps AA'd but bump procedurals were too blurred...
So i used to have to reduce the amount of AA by the texture antialiasing for the procedural bumps on individual surfaces... But i cannot see it in LW9... Hmmmmm
Maybe it was in LW5.x which also had texture velocity.

Edit:
A quick google search would show i remember correctly, notice the TextureAA button on this panel shot from LW7.x

http://www.newtek.com/products/lightwave/tutorials/surface/texture_building/images/image011.jpg

So it seems in there wisdom NT are removing useful features.