View Full Version : Screamer in 9.3 isn't saving for me now

09-27-2007, 08:49 AM
I've updated to 9.3, had screamer run a simple sample scene and it worked fine with a few nodes. I ran a much more complex scene, and even though I have all my content, including plugins in the content directory and visible, the only computer that saved a full frame was the master. One other computer saved just the sky. So, of the 1999 frames, 571 were written properly and the other half was just sky. I went back and rendered a few frames on each node at a time and none of them saved a single frame. I tried my sample scene again, and now nothing is saving. When I watch the text on each node, there is a line that says it is writing it to the proper location, but no file is actually written.

Does anyone have any idea on what could be going on?


09-27-2007, 09:19 AM
Have you updated the nodes with 9.3 Screamernet too?


09-27-2007, 09:33 AM
Good point. Yes, I put the new version of my entire program file actually onto each node, thus the 9.3 version of lwsn.exe.

10-01-2007, 11:59 AM
When I render using my master as the only screamer node it works perfectly. Using the same batch file on another computer, without the master involved in the render, the batch file spits out the exact same text "writing... etc," but there is nothing being saved to the folder.

11-02-2007, 10:42 AM
Anyone have any ideas here? The latest is that everything appears to load properly, it says its running through all the filtering passes and claims to be saving the RGB to the proper location, but nothing is showing up in the save file. The big issue is that is says it's going through all these steps, but the entire process takes 2.2 seconds. It should be several minutes.


By the way, it does the same with Tequila and Mule works only occasionally on a few computers.

11-02-2007, 12:23 PM
you could try this as a quick check,
open a dos window on one of your nodes and check you can `cd` to where you are saving the files using the path you specified

11-02-2007, 04:21 PM
I had a similar problem a few weeks ago. It turns out that Layout was still referencing my objects via the local file system path and not the shared path I had set up, so my local node always rendered fine. So local render was looking at C:\Dev\LWSNet\content and rendering fine even though I had created a share X:\LWSNet\ that was actually C:\Dev\LWSNet.

The indicator was that on the remote nodes, there were messages at the beginning of the render that scrolled off the screen - to the effect of "Could not load object "C:\Dev\LWSNet\content\Objects\whatever.lwo". And yes, the render was about 2 seconds. It wrote a file (only a couple K or so and was black). It should have been looking in "X:\..."

I removed and reloaded my objects in layout using the shared pseudonym and re-rendered (after restarting all nodes). It all worked fine after that.

One thing I did (which didn't work) was to change the default content path in Layout, then save scene and all objects... nada. The scene file was still referencing the original "C:\..." path.

I don't know what this will do to your animation as far as "new" references to objects. I was doing still renders so there was no additional work involved.

I hope you get it working. :thumbsup:

11-04-2007, 04:10 AM
I ran into the same problem recently - master rendering & saving OK, nodes rendering but not saving. It turned out the LWEXT9.CFG file and plugins folder used by the nodes weren't up to date & didn't match the corresponding ones on the master. LWSN for 9.3 seems more fussy than previous versions about this.

Re-scan your plugins folder to make sure LWEXT9.CFG on the master is up-to-date. Then find the version of LWEXT9.CFG and the plugins folder that the nodes are using (mine are on a NAS disc along with all the content), and replace them completely with the versions on the master PC. You may have to do a global search & replace on the LWEXT9.CFG to update the path to each plugin so the nodes can find them. For instance:

Module "C:\\Program Files\\NewTek\\LightWave 3D 9\\Plugins\\input-output\\avi.p"

might become

Module "M:\\LWContent\\Scream\\Plugins\\input-output\\avi.p"

where M: is the drive letter on the node that is mapped to the NAS disc.

My setup isn't the most elegant in this respect since I have to manually update it every now & again, but it suits me well enough!


11-05-2007, 09:51 AM
Well I could swear that I've tried all that, but I'm going to try and do it all again. It feels like I'm really close, but just not there yet.


11-05-2007, 09:24 PM
I have had to make sure that for the network/screamernet Layout that when I scan the plugins-thru the network, that I immediately write protect the LWEXT9.CFG. I make that read only and that helps. I have previously seen the paths revert from network paths to regular paths, without my having to do ANYTHING. I swear to mmmph.

11-06-2007, 02:13 AM
That's because you have autoscan on in Options. LightWave v9 can check for plugins at startup, the same way it now checks for fonts. You have to turn it off for use with Screamernet otherwise you lose the nice network-aware paths you set up.


11-06-2007, 08:12 AM
Thank you X 10!