PDA

View Full Version : Low CPU usage when rendering



bilbobagins
09-23-2007, 02:28 PM
Whenever I'm rendering layout's CPU usage is very low...

jumps around from like 4% to 12% and only uses like 700 megs of ram

ive got a core2duo 2.4 and 2 gigs of ram, hyper threading is on

any ideas?

Sensei
09-23-2007, 06:15 PM
What's your Render Globals > Multithreading setting?

bilbobagins
09-23-2007, 06:48 PM
it is set to 2

Sensei
09-23-2007, 07:20 PM
Can you attach your scene & objects? Do you have any pixel-filter or image-filter that is executed at the end of rendering? They could be not multi-threading friendly..

bilbobagins
09-23-2007, 07:28 PM
well I cant upload the scenes/objects no, but I just made a 1.5m x 1.5m ball and loaded it and just started rendering a bunch of frames (480x640)...

renders the frames in like .2 and .3 seconds but in windows task manager in the performance tab, it only gets up to 9-14%

Sensei
09-23-2007, 07:40 PM
0.2-0.3 second per frame? That's obvious that such easy scene is most of the time being prepared to real rendering, and then saved to disk. These both actions can't be multi-threaded and are done by one thread. How long takes your real scene to render a frame?

bilbobagins
09-23-2007, 08:15 PM
my real scene takes like 2.5-2.7 seconds a frame

bilbobagins
09-23-2007, 08:16 PM
its just that it doesnt seem that my CPU is using anywhere near its full power

bagou01
09-24-2007, 02:06 AM
i've got the same problem but when calculating dynamics,i'm at almost 5 minutes per frame,and my cpu usage is not even at 10 percent,i've a mac pro quad and would like it to be usefull
any idea?