PDA

View Full Version : Displacement Question



othornton
09-19-2007, 09:19 AM
Hey,

Ok, so here's the problem. I have a human body mesh that has a uvmap divided up into 3 regions. That's 3 regions, one uv map. The mesh has three displacement maps that I need to link to a single object. Has anyone else ever dealt with this?

With the displacement being input through the object tab I only know how to link one region at a time.

I'm guessing there may be a way to do this with Nodes if at all, but I'm a bit unclear as to how. Any help on this would be appreciated greatly!

-Oliver

MooseDog
09-19-2007, 10:11 AM
http://www.newtek.com/forums/showthread.php?t=73824

this might get you going in the right direction i hope.

othornton
09-21-2007, 10:03 AM
Hi Moosedog,

Thanks for the reply. That thread is no help though, as my problem is distinctly different even though it also deals with displacement and UVs.

For anyone not familiar with the concept of UV region mapping, here is a link to a picture of it from the ZBrush info site.

http://www.zbrush.info/docs/index.php/Image:MayaPipeline_MultiDispMap.jpg

Using this image as reference, my UVs are laid out in regions 1 2 and 3 in the same single UV Map.

In Surfacing this can be extraordinarily helpful, allowing for a single mesh to be broken up into chunks that will receive a much higher resolution texture than if the UVs were all crammed into one region.

That being said, unfortunately Lightwave's displacement node setup only allows for one region to be used by a displacement map... or at least as far as I know.

If anyone out there knows how to use UV regions with LW's displacement, I am all ears.

Thanks!

-Oliver