View Full Version : Hypervoxel's problem: need help.

09-10-2007, 08:44 AM
I am having trouble with my hypervoxels and was wondering if anyone could help me figure it out. Here is a render element showing the problem.. (http://4dartist.com/cgtalk/smokeproblem.mov)

There seems to be a shadow that is crawling up the smoke. It is a massive smoke trail so i can understand if any shadow map was being used it probably would have problems covering the entire trail, but my first render had 'textured shadows' ON so i turned it OFF for the second render, which is attached by the way. This render has only volumetric shadows ON. Both have the exact same moving shadow. I've had this problem before in other projects too with similar smoke trails.

I was thinking maybe to make 4 emitters or more and have them turn on and off over a frame, so basically the total size of each trail would be a quarter of the original's size. Maybe then if there is some sort of texture shadow map it would be a little less area for it to cover.

Thanks for any help!

09-10-2007, 08:54 AM
Oops i took too long on my edit. I just wanted to add:

The shot has a lot more prior to what is in the .mov. The smoke trail starts at the ground and goes a little longer than whats in the .mov too. It actually reaches about 45km high in the shot, which i know is a huge distance, but the way it's setup it looks great over the entire shot and everything is working spot on except this shadow problem. (thinking out loud) I could try making everything a child to a null that is scaled way down, and get my scene under like 1km and try rendering it. Probably have to do some HV tweaking but maybe LW just doesn't like the large numbers for the HVs.


09-10-2007, 09:05 AM
Thought this might be helpful too. Here is my list of nulls:

The blue item is the rocket model, but it has shadows (cast, self and receive to OFF) and set to MATTE object and alpha. The purple stuff is just for camera, and only null objects and a camera. Smoke trail is the hypervoxels, which gets it's motion from the Ares null. Both lights are 'directional' lights and shadows are set to raytrace shadows.


09-10-2007, 09:16 AM
Try turning off align to path if you have that on.

09-10-2007, 09:24 AM
Yep I turned align to path off because the hypervoxels would start twitching as they slow down to 0 velocity.

ben martin
09-10-2007, 10:10 AM
Are you using 9.0, 9.2 or 9.3?

I have noticed the same problem with Volumetric FX (xStream 6 - shadows) if I use "Shadow Map" instead of "Raytrace" shadows. :thumbsdow

Also you can try (just for test) to change your Hypervoxels from "Volume" to "Sprite - 1 Slice" (adjust the sprite values to look more like smoke) and anim test to see if that "shadow crawling thing" still on showing. :question:

ben martin
09-10-2007, 11:33 AM
Forget about that silly sprite test suggestion.
Seems to me that sprites do not receive or project shadows of any kind!
Though you can always try the test using HV surfaces instead!

09-10-2007, 11:50 AM
I'm using UB v9.3.

Hum I may try the surface HV test, but if it does or doesn't have the problem, i'm not sure what that would be telling me.

ben martin
09-10-2007, 12:22 PM
I'm using UB v9.3.

Hum I may try the surface HV test, but if it does or doesn't have the problem, i'm not sure what that would be telling me.
Well, the idea is to realize if the problem is really related with the HV render engine (I believe it is) and report it to NT.

My attached test movie was rendered in Lightwave using xStream 6.
xStream 6 works as a volumetric plug-in in Lightwave.

If you look carefully you'll notice on the right-down side (while the palm trees are passing by) a shadow problem similar to the problem you are experiencing with your smoke.

This can be important to figure out if Lightwave volumetric is bogus coded or not.

So, testing you scene using “volumetric/surfaces” can help to figure out if the problem exists or is a simple "parameters" fine tuning issue.

09-10-2007, 02:29 PM
Ya i see your point. I think I'm going to run a few tests tonight. I'm going to turn volumetric shadows off. and see what that does. then maybe if i can't get it too look good w/out shadows, i'll turn them back on but crank the quality. Problem is render times are already kinda high. *sigh* lots of testing and figuring out to do. I HAVE to get this working though..

ben martin
09-10-2007, 02:51 PM
Well, I have a render farm here, if you need help to perform such testes and try to figure out a solution just send to me you HV scene (only need the particles emitter and the HV set) and I also perform tests here and let you know if I can reach a useable solution to your problem!

It’s the only help/solution I can offer right now! :)

my email: ben_martin_box(at)hotmail.com

09-10-2007, 06:02 PM
ben martin- hey man, thanks for offering to do that, that's very generous of you. I think i have a compromise that will work for now. I did a quick test with volumetric shadows turned off as well as textured shadows (which was off on the linked version) and the problem appears to go away. So i guess it's a problem with volumetric shadows and the scale of the scene being too big.

The compromise is, it doesn't have the error (good) but i lose the lighting, it's now just soft white instead of light on the sun rise side and dark on the backside. (bad)

So for now it's ok and i think it'll be fine in the final composite. So i'm happy.

Thanks so much for your replies you guys, it's very helpful to come here and work things out sometimes when I get stuck! :screwy:


ben martin
09-10-2007, 06:51 PM
Cool, I'm glad that you partially solve the issue!
Now, I guess it is time to report your finds to :newtek: so they can fix that such annoying problem! :hammer: