PDA

View Full Version : Help! - UB ScreamerNet setup



Meshbuilder
09-05-2007, 09:32 AM
I'm having trouble with UB ScreamerNet..
The ScreamerNet app on the network computer finds the "Job" and "Ack" files like it should and I can see the node in the ScreamerNet controller on the local machine. But when I render the node doesn't find the LW scene file..

:help:


The ScreamerNet Node changes the directory:

"sendack: Initializing
MachOMac
Current directory is now "Volumes/Quad-Xeon-HD1/Applications/LightWave3D/Content"."

("Quad-Xeon-HD1" is the network mounted harddrive.)
But when I start rendering it can't load the scene files on that adress..

"LightWave command: load.
sendack: Loading
Loading ":Application/LightWave3D/Content/scenes/DiscWorld.lws."


Here's my Apple Script:

tell application "Terminal"
do script "/Applications/LightWave3D/ScreamerNet5 -2 -c/Volumes/Quad-Xeon-HD1/Applications/LightWave3D/Configs -d/Volumes/Quad-Xeon-HD1/Applications/LightWave3D/Content /Volumes/Quad-Xeon-HD1/Applications/LightWave3D/Commands/job1 /Volumes/Quad-Xeon-HD1/Applications/LightWave3D/Commands/ack1"
end tell

John the Geek
09-05-2007, 07:39 PM
Hmm, this is an odd one.

I'm going to presume we aren't seeing copy/pasted text here, since it's littered with mistakes.

sendack should be sendback

Application should be Applications

: should be /

ScreamerNet5 should just be ScreamerNet

Can you send us actual text instead of retyping it? Otherwise it looks like it shouldn't be launching at all.

=)

Meshbuilder
09-06-2007, 01:30 AM
Hi!

I'm sorry for the bad text writing..
Anyway it does load the scene correctly now.

But a new problem appeared. It couldn't save the renderered image.
"Error: The RGB Output directory specified does not exist, no image saved"

So I checked the scene file and it seem that LightWave tried to save the image locally.
SaveRGBImagesPrefix /lwrender/render/disc

I changed it in the text editor to this and now it work! :dance:
SaveRGBImagesPrefix /Volumes/Quad-Xeon-HD1/lwrender/render/disc

yaschan
02-15-2009, 10:36 PM
I am using ScreamerNetUB Launcher and while everything seems to work perfectly, my effort dies into "Error: The RGB Output directory specified does not exist, no image saved".

I checked my scene file and the output path is correct in my case.

I have tried everything, creating a disk image and directing files to there, or even creating a temp folder in the root of my hard disc..

I really wonder what's reason..

Chilton
02-15-2009, 10:46 PM
Hi Yaschan,

Try changing your output directory and see if that works.

And I know this sucks, but try to eliminate any unicode characters in the paths. Not all of LightWave is Unicode compliant, unfortunately

-Chilton

yaschan
02-15-2009, 10:51 PM
Yes I did. I have tried to change the RGB output directory to various locations, including a disk image or various folder in content directory.

I checked the scene file has correct path. No unicode characters at all.

Hmm.. interesting.

yaschan
02-15-2009, 11:24 PM
Here is piece of my scene file..
I can swear the folder exists..

But no matter where I direct the files, I get the same error..

OutputFilenameFormat 3
SaveRGB 1
SaveRGBImagesPrefix /Users/YuuPro/Lightwave/RGB/onetwo
RGBImageSaver LW_TIFF24(.tif)
SaveAlpha 0

Scazzino
02-16-2009, 09:35 AM
Try it with the free Lite version of DLI_SNUB-Launcher (http://dreamlight.com/webshop/utilities/snublauncher.html). At least then you'll be sure there are no syntax errors in your command line. You just drag/drop the folders and files onto the appropriate fields and DLI_SNUB-Launcher will take care of building the proper command line to launch ScreamerNet.

:goodluck: