View Full Version : Z buffer with volumertics?

08-30-2007, 07:55 AM
Does anyone know of a way to exprot Z depth info from a volumetric render
(HV or HD instance)?

I have been doing a lot of search but cant find anything ...
there is another thread that used a distance to camera gradient to color from
white to black a channel so that this could be used as Depth info..


08-30-2007, 08:11 AM
Been wondering about that also, but haven't had time to test it. I'd like to see the definitive, easy to implement answer.

08-30-2007, 01:13 PM
How did this happen??


MonroePoteet can u please tell how you managed to get Z info out of that HV?

I have been trying to export RLA RPF EXR and nothing...

08-31-2007, 09:08 AM
Havent tried to see Z-Buffer of HVoxels HD_Instance for long time, last time in LW8.3

Z-Buffer was inaccessible until LW7.0.
Personally I was involved in asking Newtek for the opposite because Sasquatch and HD_Instance didnt work with Evasion X-DOF.

Later, I found a bug in HD_Instance that was fixed after some time.

If Z-Buffer and Volumetrics is now broken, well, it used to work :(

09-01-2007, 02:43 AM
Not sure if this method works:


Maybe asks Pictrix? My japanese is ... rusty ;)


09-01-2007, 04:08 AM
thanks and efxaristw for all help ppl,

I tried almost everything but the only solution i found was cheating in post using luminance from the rendered HV's

panikos : i dont usually work with HV so i cant tell what is going on
i am using 9.2 right now and cannot upgrade to 9.3 beacause we are in the middle of a big project in the studio.
I will do some tests with other volumertic stuff like sas or TB infinite plane to see if it works there...

09-01-2007, 04:10 AM
double post

09-01-2007, 04:27 AM
Ok Sasquatch works with Z buffer export
HD instance,Hypervoxels (Volumes or surfaces),and TB infinite plane... dont work..

09-01-2007, 05:33 AM
Γεια σου πατριώτη, πάντα δίπλα, σε ήλιο και βροχή.

Seems that the changes in the volumetric SDK caused some problems.
Personaly, depending on my needs, I have LW8.3 and 9.3 installed :)

Καλή τύχη

09-01-2007, 06:44 AM
Compatriot :)

I made 2 tests and observed.
Polys and HVoxels are rendered fine in ZBuffer.
I tried TB_IPlane that corrupted the ZBuffer.

I havent tried HD_Instance but its suspicious that is broken.
You can contact Graham for this.

09-01-2007, 12:44 PM
I tried HD_Instance 1.72 and viewed the Depth Buffer.
Its effective.

As far as I can see, the distances are normalized, so usage of TB_IPlane
generates Black & White Depths due to the huge depth distance of the horizon.

So, after revising everything, I think that there is no problem neither with Newtek or with 3rd party plugins mentioned.


09-01-2007, 04:02 PM
Sumpatriwth euxaristw gia th sumparastash :)

Yes i see what you mean with TB_Iplane i get the same result...
I will try more things tomorrow to see what is going on...

I tried
a)exporting the Z buffer with DSTORM's exporter
b)exporting the Z buffer with the Render Buffer EXprot that comes with LW
c)exproting the Z buffer with PSD exporter
d)exporting the Z buffer with the Aura exporter and bringing it in TVPaint
e)seeing the Z buffer with Buffer Viewer

anyway ..:)

09-01-2007, 04:40 PM
ok it was 9.2
i installed 9.3 on my laptop
(that's the good thing about a usb dongle...:))
and it works ...