View Full Version : Dialectictric about to cause an aneurism

08-19-2007, 01:44 AM
I did a search and found a preset. But it didn't help. I also used dialectric with my own settings on one glass object and it worked great. However, when I tried it on a window object, it didn't seem to matter what setting I used. The glass turns out black and non-transparent, regardless.

I'm wondering... It is a double-paned window. Could that be the culprit?

The surface contains two surfaces; one after the other, and they are both single-sided and facing in opposite directions.

However, taking that into consideration, I removed the second pane and attempted it again on just the remaining object; still black.

Any idea what might be causing this?

08-19-2007, 05:39 AM
FG radiosity ?

08-19-2007, 11:57 AM
Nope. Didn't try it with radiosity. Tried it with DLP 1 + AS for a quick test; thought that was the problem. Then I tried it with classic medium and no AS; still same thing.

What's weird though, is the interior glass that I used dialectric on render just fine (slow though). It's just the exterior glass that insists on rendering black, solid, and with a slight reflection.

:D Now, I know that Obsidian is a volcanic glass, and that the literature for the dialetric says it renders with true glass settings. But I had no idea it was literal.

But seriously though, I have no idea why it's only the exterior glass that's doing it. The only thing I'm left to ponder is that the interior objects are closed, single-sided objects (solid), and that the window is simply 1 polygon, in it's own layer, single-sided, and not really attached to anything. Maybe I'll test that hair-brained theory out today if I have time.

08-19-2007, 01:30 PM
I lied. The windows are closed objects - my bad. I've just run a few more tests with different settings, and I still can't seem to get it to render properly. Yet, I decided to turn a few more internal objects into the same material out of curiosity and they all render as expected; like glass. Has this happened to anyone else? Anyone know why? I'm afraid I'm more curious now than I am frustrated as to the inner workings of this node.

08-19-2007, 03:02 PM
the poly's aren't flipped by any chance ?

have you tried replacing just the window poly

08-19-2007, 03:28 PM
I can't see them as flipped, the faces are all facing outward. I also checked to see if maybe I'd doubled the object by mistake (done it before out sheer button happiness). But as for your suggestion, I just thought of that one myself. When I get back, I'll give that one a try and let you know if that worked.

08-19-2007, 04:01 PM
how many ray recursions?

did you change the default 16 to a lower number?

08-19-2007, 04:33 PM
Hmmm. Nope, reconstructed the object from fresh; same thing. Also, I thought the recursion might have been the problem (I generally have it set to 8). So I bumped it up to 16, and still no. It's weird. Everything 'inside' renders with it just fine. It's only the object separating the outside from the inside that doesn't seem to want to work with it.

08-19-2007, 08:37 PM
I did a few more tests and parred the problem down to a rendering issue. after checking and unchecking each option I found that raytrace transparency and raytrace refraction were both the culprits. Everything renders as expected with those two unchecked.

Strange that it was only the outside-facing glass though. Hm. :D

Mr Maze
08-20-2007, 12:12 AM
That is strange. My understanding is that ray-traced transparency has to be turned on for dielectric material nodes.

08-20-2007, 02:01 AM
hm. I did try in at .5 and another at 90, though, and it still had the black appearance. I'll play around with it some more tomorrow and see what I can come up with.

One more thing, I found that with GI (which I hadn't tried until tonight), that it didn't matter what I had checked or unchecked; it still appeared black.

The object is a rather large office-style window, if that helps for any more thoughts/ideas on the matter.

This is turning into one of those things that I know I could easily give up on and go with some other form of shading. But my stubborn side and curiosity over the matter is simply driving me bonkers and causing me to want to solve it, as long as it's solvable.

08-20-2007, 02:49 AM
is there a way you could upload the object or part of the object so we can take a look at it ?

08-20-2007, 07:11 PM
Okay. I haven't had much time to play around with this today. But here's the object in question. My only last guess is that maybe it's too thin. Hopefully one of you will know. :D

08-21-2007, 01:05 AM
Try opening it in modeller and pressing 'w' to get the info panel open. How have you managed to get 30 polygons for that shape when you don't have any bevelled edges?

I'd start again with a simple 6 poly box and go from there.

08-21-2007, 01:06 PM
Okay... I feel like a total knob right about now. I zipped the wrong flipping file and sent you all something so I could embarrass the hell out of myself, because I'm an idiot like that, and figured I'd let you all know. 8~

- one of the top ten reasons I don't post in forums very often.

Anyway, the window was done from an actual 'Box', and here's the 'real' file. That other one was one from an older version that got messed up somehow, and I thought I deleted it... But apparently not.

However, the one I've attached (and hopefully it's the right one this time) is the one I'm having that blackish problem with, and to my knowledge, it's a very thin 'Box'.

I'm so friggin embarrassed right now...

08-21-2007, 03:34 PM
I can feel the glow from here ;)
Well I can't see anything wrong with the object. I dropped it into an empty scene, put a background gradient on and hit render.

08-21-2007, 04:40 PM
What settings did you use, may I ask? Because when I rendered it with GI and with regular raytracing, it turned out black for me, on two different computers (I even did it again before I uploaded it with the same problem). I've done it with and without any scene setp-ups as well, and as I mentioned earlier, the only time it does appear to work is without GI, refraction, and reflection.

Also, maybe I should aslo ask if you rendered it with 9.2 or 3?

08-21-2007, 05:17 PM
I've tried just about every combination of GI I can think of and nothing makes it render black. The only way I could get it to render anything like black with your node settings was by increasings it's size by somewhewre between 60 and 100 times its original size and even then it wasn't totally black.
Try starting with 0% absorption and white as the dielectric colour and see if that renders any better. If it does gradually increase either/or until you get what you want.


08-21-2007, 05:36 PM
That's weird. I tried it like you did, with a gradient in the background and you're right; it renders fine. However, when I add an image in the background which is what I was doing all this time (and I tried more than one just to make sure), I get the black result. Could you do me a favour and try a bg image just to see if it happens to you as well?

At least I've managed to par it down some. Thanks for that :D

08-22-2007, 02:00 AM
Yep. Agreed. Dropping a background image in renders it black. Switching nodes off and it renders transparent, SO LONG AS THE REFRACTION IS SET TO 1.

Even without nodes, as soon as the refraction is other than 1 than you get a solid box with varying shades of grey depending on transparency level.

Hmmm Have I missed an obvious setting? or is this a bug?

08-22-2007, 09:38 AM
I'm beginning to think it's a bug. So far, the only work-around I've come up with (which was last night after you found it worked fine with a gradient) was to just create a simple polygon with the bg as a texture and high luminosity on it and placing it right outside the window while having lights and shadows ignoring it. However, I'd really prefer to just have the bg like I normally would.

But the strange thing is that all the other objects (which are far more complex) with dialectric rendered as I would expect, and they're all in the same scene.

Do you think I should report this as a bug to Newtek, then?