PDA

View Full Version : How to use Normalmap with Simpleskin?



JerryJang
08-08-2007, 03:18 AM
Hello!everybody:

Recently I try to apply simpleskin node to an object that applied normal map,but I found if I use simplekine node,the effect of normalmap will gone.

I also tried to link normalmap node to simpleskin,but still got the same reason.

I just want to know if there are anyway to apply both simpleskin and normalmap in one object and got both effect for the object.

Thanks for anyone that answer my question.^_^

Sensei
08-08-2007, 01:53 PM
Where are you connecting normal map input? To Surface node, or to Simple Skin node?

JerryJang
08-08-2007, 07:14 PM
Both ways are tried....

First,I connect the normalmap node to surface node.The result is right.I got the normalmap effect.

Then,I open simple skin node and connect to surface node,the normalmap's effect gone...The result is wrong....

I tried to let nromal map node connect to simple skin's normal,and let only simple skin connect to surface node.The result still wrong...

Do I do something wrong with it?

Sensei
08-08-2007, 07:41 PM
It's normal that material overrides regular Surface node Normal input, but it looks like LW bug that it also does it with Skin node Normal input.. Report a bug to NewTek, they probably have no idea about it..

JerryJang
08-10-2007, 04:13 AM
That's too bad....-_-|||

And thank you for your information.

Eekster
08-11-2007, 02:07 PM
Aloha!

Humm, this is a model with ~960tris and a tangent nm connected to simpleskin node.

http://img23.imagevenue.com/loc1027/th_62778_normalmap_test_001_122_1027lo.jpg (http://img23.imagevenue.com/img.php?image=62778_normalmap_test_001_122_1027lo. jpg)

/Eek

Eekster
08-11-2007, 02:07 PM
double post. doh

JerryJang
08-12-2007, 11:43 PM
Sorry...Double post..deleted...

JerryJang
08-12-2007, 11:44 PM
Sorry....Does it means I need to apply Normal Map to a triangles object then conntect to simpleksin node....Or....??

What is tangent NormalMap means?Is there are any different in normalmap file?




Aloha!

Humm, this is a model with ~960tris and a tangent nm connected to simpleskin node.

http://img23.imagevenue.com/loc1027/th_62778_normalmap_test_001_122_1027lo.jpg (http://img23.imagevenue.com/img.php?image=62778_normalmap_test_001_122_1027lo. jpg)

/Eek

Ztreem
08-13-2007, 08:21 AM
You must use tangent normal maps with the normal input in the node editor. So if you don't have a tangent normal map you have to convert it with some nodes(I don't know how) or do a new normal map in tangent space instead of object space.

JerryJang
08-15-2007, 09:06 PM
I've tried use tangent normal maps(Exported from Zbrush) and then
use both ways above,bust still can't get correct result..Can you post your node connection situation here?Thank you for your help..




You must use tangent normal maps with the normal input in the node editor. So if you don't have a tangent normal map you have to convert it with some nodes(I don't know how) or do a new normal map in tangent space instead of object space.

Eekster
08-16-2007, 12:08 AM
Aloha!

Humm...have you flipped the map frpm z-brush?
You could always apply the nm in to the color channel first to see so it matches the models as you thought, and if it does, you should just have to plug it into the normal on the skinshader.
And the lightning also has a big part of how much the nm effect has, so test with some differnt light setups could be an idea.

/Eek