PDA

View Full Version : Activating bones, they jump away



lexa444
08-06-2007, 03:41 AM
Hello,

I've got a problem with my rigging.
I've made bones in Layout, and selected them all, then activated them.
For most of the rig ths went well, but for instants the finger bones, became bigger, and made a small jump out of the hand.

Now I searched this forum for a solution, and I found that you need to reset the bones before you activate them, Is this the solution?

How do I reset the bones?
Or do I have to Rest them, (before/ after) And how do I do that?

Thnx for your help

lexa444

Dodgy
08-06-2007, 12:30 PM
If things jump, select all your bones and press 'r' to rest them :)

lexa444
08-07-2007, 08:03 AM
They jump when I press "r",

That's the problem, I activate them and the jump away, not al, but some of them.

Do you have a solution?

thnx lexa444

j__
08-07-2007, 09:54 AM
1. Make sure you're not trying to scale bones into position by using the scale tool (h/H), use Rest Length.

2. Make sure you create a keyframe (at 0) immediately after you've put your bone into its rest position.

3. Have you got IK on or something ? Turn it off when working on your hierarchy.

kosmodave
08-07-2007, 12:44 PM
Hi Lexa44,This could be a Lightwave 9.2 or Lightwave 9.3 issue as I am having a similar problem with bones. I have created a skellagon rig in modeller and then converted to bones in Layout, the problem arises when I change the parenting. I wanted to parent the leg bones to a root bone but when I do this the leg flies up above the head. However this does not occur in Lightwave 9.0. Any ideas?
This is my first post.... Been watching for ages, There is definiately a great
bunch of people on this forum.

Regards Dave Banks

kosmodave
08-07-2007, 01:21 PM
Just had another play with this. I have two boot drives on my system with Lightwave 9.2 installed on both. I tried changing parenting on converted skellagons on my other boot drive with Lightwave 9.2 and everything worked OK. Went back to my other Boot drive and Lightwave 9.2 and found it still does not work. I then copied the Lightwave config files from my working 9.2 Boot drive to to the problematic installation and found that the bones jumping problem was corrected. I will try to narrow down what part of the config files are being corrupted.

Dave.

kosmodave
08-07-2007, 01:46 PM
After comparing the setups of the two versions of Lightwave I noticed that the working version had Parent in Place checked in Layouts Options panel but not in the version that was giving me problems. So no corrupt configs here just a corrupt brain. Must be an age thing!
Have you checked Parent in Place Lex?

Dave.

lexa444
08-08-2007, 07:11 AM
Yes, I've got Parent into place on.

I've located the problem, in the bone properties, I had to asign them to the Null object in the scene, all the bones are now activated and back into place.

Thnx for your help folks

greets lexa444