PDA

View Full Version : LW 9.2 renderings darken than should be when using "arbitrary" range for rendering.



dbmyers
08-04-2007, 02:21 AM
Has anyone run into this problem? If I render with (F9) on any frame, no problem. If I render (F10) on single range, even if I ask it to render every 5th frame for instance - no problem. If I render with "arbitrary" range using (F10) and listing the frames I want, the textures are darker and unacceptable. If I use "Keyframe" as the range type, the first keyframe (0) is fine but each keyframe thereafter is too dark. Having said that, I went back and did some more tests. First, this is the first time I've used nodes for surfacing. The object does turn and I am using a hetero terrain node with two different levels of darkness and I probably have the size of the pattern two big so that in my starting position the surface was as light as I wanted (because the entire surface is in the light area in the first frame). It may be that my object is turning through this surface into the darker texture (which I have assumed would be fixed to the object and would turn with it), but the reason I didn't find this until I tried using the arbitrary range to do selected frames is that when I do an F9 render on the selected frames they don't come out darker. Its as though the effect of turning into the darker part of the texture is not taken into account when I use F9, but is taken into account if I use F10. I don't understand why the object would turn and the texture wouldn't and I don't understand why an F9 render wouldn't have the same effect as using the abitrary range. Does anyone have any inkling as to why the object is moving through the texture or why simple F9 renders come out differently from the F10 renders with arbitrary on, for the same frame? This is totally baffling. If I remove all of the keyframes so the object does not rotate. The image comes out the same regardless of frame number or whether I use F9, F10, or whether I use arbitrary or keyframe. I did preview renders on all frames I chose to use with the arbitrary rendering and they were all ok. When I let them render overnight with the arbitrary rendering, all but the first frame got darker which is consistant with the object rotating through a light-dark pattern. Thanks for any perspectives people may have on this.