View Full Version : HUB & Modeler & Layout communication

Geoff Vane
07-22-2007, 04:03 AM

I finally totally had it with the evil search function of this forum. Try typing in "hub problem" and it says "this page can not be found". This happens with 30% of my search queries. The greater the problem, the less chance the search function will do it's job. Mailed the webmaster again. I think he's dead.

I also am totally fed up with the hub problem. No, I'm not going to use the "-0" option, I have to work fast. Yes, I have deleted the configs, rebooted etc. Yes, my firewall is configured correctly.

Layout is not starting up when the hub is used. Modeler starts a new instance of layout everytime I switch.

Does someone have a real solution?

I'm glad newtek doesn't build airplanes...

07-22-2007, 04:52 AM
The page not found error tends to pop up when there are numerous potential responses. At least that is my experience. Putting in a more refined search usually helps. Try going into advanced search, choosing the 'search titles only' and enter hub as the search term.

Geoff Vane
07-22-2007, 05:23 AM
Thank you for helping me. :)
I'll try this next time.
The advanced search was just as bad in the past but I did not search on titles only. Maybe that helps.

This was a more general search query, but this also happens with more specific queries. It is unpredictabale when a sentence will cause a crash.

07-22-2007, 09:41 AM
This is a very basic problem, I know...but I am new at this and it is frustrating me. I am trying to learn Modeler..I'm trying to follow a tutorial...but can't seem to get to first base.

Problem is....In modeler you have top, front, right and perspective.

Trouble is... when I create a box...(stretched it in two dimensions)...the perspective still looks one dimensional? How do I get the 3D look from perspective view?

When I go to modify and rotate the perspective remains flat...but, the other three perspectives take on a 3D look and move in dimensional ways.

In the tutorial he just drags the box open and he has a 3D perspective. When I do the same...mine is one dimensional? I can't seem to get to the point where he is so I'm not understanding what's happening. I know its probably just a setting...but not sure where to look?


PS. A really good tutorial reference for Modeler would also be appreciated if you happen to know a few off hand?

07-22-2007, 10:11 AM
The hub problem... can't think of a solution offhand. I've written it off as "just one of those things". Mine works about 90% of the time, but I don't use it much anymore. I've screwed up too many models that way, and it's only slightly faster than simply opening the programs separately.

As for the box thing, try creating it in the perspective window with the CTRL key pressed. That will cause a perfectly symmetrical box to be created.
The problem you're having is you're only creating 2 dimensions. You could create your box in, say, the top view, and dsrag it out, and then go to a left or right view and then you'll have that 3D thing. You could also press the n key and the Numeric panel will open, and you can manually type in number values for the length, width and height.

07-22-2007, 11:38 AM
Thanks for your help, IMI! :)

07-22-2007, 11:46 AM
No problem. :)
One thing I find enormously helpful is to open the Numeric panel and just leave it open at all times. Most of the tools in Modeler, as well as the 3rd party plugins have some sort of manual numeric adjustments you can make, but only through the Numeric panel. if you want extreme precision, the Numeric panel is the way to go. :)

07-22-2007, 11:22 PM
PS. A really good tutorial reference for Modeler would also be appreciated if you happen to know a few off hand?

Take a look here (http://www.suture.net/tutorials/modeling/index.php).

Geoff Vane
07-23-2007, 02:32 PM
Okay, back to the hub problem. Please don't mess up this thread any further with non-hub issues.

I need to work on a model while it is in Layout. I don't see how I can tweak a model with many layers without HUB. I would have to save over it and I never do. I increase the version number per save. This means the scene looses contact without hub. Replacing with layout all the time is no option either. It messes up the layer and texture structure, when certain objects switch layers during the modelling process.

I just want a working hub! How hard can it be to make a working hub? It's just unbelievable! These people can program radiosity, but no information exchange between layout and modeler... :thumbsdow

Does ANYONE know WHY the hub fux it all up? I have studied the .cfg files but I don't see any clue in there. Can I mess with the registry to clean things up? Why does it work on pc A and not on pc B? It's not biological, is it?

No more workarounds, talk to the hand... :twak:

07-23-2007, 05:58 PM
I had problems with the Hub starting up when launching modeler or layout in 9.0 most the time and found out that if I diabled my norton internet secruity and tried it would come up fine. For some reason because the hub communicates with layout and modeler using TCP/IP and norton would mess that up and prevent the Hub from launching properly. In 9.2 I found works OK with norton but takes a while for the Hub to come up with out disabling norton.

07-23-2007, 07:54 PM
The hub has play like crap on my tower since v 9.0. I've tried everything people have mentioned, and none of them worked. My work around (still hoping for this to magically resolve though), is to have a shortcut to the hub. Before I start layout or modeller after a fresh boot, I start the hub up. I also have the hub to never shut down. Once it's running, Layout and Modeller run fine for me.

Geoff Vane
07-25-2007, 09:29 AM
I'll try that Skank. I have my firewall configured correctly, so I do not think it's that. It's just the windows firewall and shutting that down does not make any difference. I have tried starting the hub first, but not right after startup. I'll configure it not to go to sleep after 1 minute standard time. The hub doesn't go away when I quit layout or modeler, but it used to do so in the past. 8~