PDA

View Full Version : Omega object inside double-sided transparent object?



Scazzino
07-20-2007, 10:52 PM
Has anyone been able to use an object with the omega shader inside (or behind) a transparent object that's double-sided?

I'm getting shading artifacts on the omega surface as seen in this test. The same thing does not happen if I use Kappa or Sigma instead, but Kappa doesn't look as good and Sigma doesn't let me control the specular the way I like...

:question:

Scazzino
07-24-2007, 02:02 PM
The artifacts I'm talking about are the triangular facets that appear on the enclosed larynx, trachea and thyroid... turning off double-sided on the enclosing neck/torso object gets rid of them, but then I can't use the neck/torso to cast shadows onto the enclosed objects...

Anyone have a workaround?

connerh
07-24-2007, 11:20 PM
What all are your settings in Omega? Are you using single or multiple scattering, how many recursions, etc?

Scazzino
07-25-2007, 08:02 AM
It doesn't seem to matter. Here's the stripped down scene with the node map. I've tried changing every setting. Whenever I turn on the transparent torso object, it messes up the Omega surfaces of the cartilage and trachea inside. The outer transparency seems to mess up the handling of the double-sided polys in the Omega surfaces...

I even tried replacing my cartilage surface with the greenish Omega surface posted from this thread (http://www.newtek.com/forums/showthread.php?t=71127), which had the same problems when inside the torso transparent surface...

I'm going to run a test with real air polys instead of using double-sided with the spot-info/switch to see if that might work better.

Scazzino
07-25-2007, 10:00 AM
Using real air-polys rather than double-sided/switch didn't help either...

:bangwall:

Jim M
07-29-2007, 04:05 PM
Well I notice your not using a switch node, but are blending materials.
I imagine this is part of the problem. Use a switch node instead of the material mixer node. My 2p.

Scazzino
10-05-2007, 10:12 AM
The problem was a bug that's been fixed... :thumbsup:
Here's the finished illustration (http://www.newtek.com/forums/showthread.php?t=71935) and animation (http://www.newtek.com/forums/showpost.php?p=598799&postcount=29)...