View Full Version : Can't figure it out: LWSN on Win XP 32

Mr Maze
07-18-2007, 06:50 PM

Today I tried to set up ScreamerNet....didn't seem so hard but I am having an issue. I can't get LWSN to start on a node. The command line window opens, but then states "Error: Can't open message table." and then closes.

Any ideas?

07-19-2007, 09:15 AM
The node is not "seeing" the configuration files, make sure to use: -cYourConfigDir on your command line, where "YourConfigDir" is where the LW configurations are.

I got a free application to run nodes, just register and download:


Mr Maze
07-19-2007, 10:49 AM
Ok I will take another shot at this. It looks like Tequila Scream Runner can start the nodes from one computer, is that right? Would make things easier than running around to all the different computers and getting them going...

Thanks for your help!

Mr Maze
07-19-2007, 11:41 AM
Man, I have tried as many different ways as I can think of. My configs are located at C:\Lightwave\configs (configs is the folder where all of my config files are)

and it still comes back Error: Can't open message table.

Mr Maze
07-19-2007, 01:03 PM

I didn't have all of the program files copied into the right folder where LWSN was supposed to be running from. Now its up and running!

07-19-2007, 02:59 PM
Mr Maze,

If you have more than 1 machine you may want to copy your config files to a network drive, just remember that every time you add plugins or the configuration files change you must copy the new ones.



Mr Maze
07-19-2007, 06:22 PM
Well, now I have it all up and running - to a point. Right now, the network consists of 4 computers:A) AMD dual core (nodes 1 & 2), Dual Xeon (Nodes 3 & 4), Pentium 4 HT Laptop (Node 5), and Pentium 4 HT Desktop (Node 6). It could expand to one more Pentium Centrino Laptop, and maybe a file server with a Pentium 4 HT.

They all load the scene fine. they all render. they all say that they are saving the file to the proper place in the content directory (Z:\Content\Images\Renders). HOWEVER :bangwall: Nodes 5 and 6 don't actually write a file. Only nodes 1-4! ??????? I don't get it.

07-19-2007, 06:33 PM
1) Nodes 5 and 6 do not have access to the render dir or...
2) Nodes 5 and 6 are not reading the correct LWEXT9.CFG file, if you can see on the nodes windows something like "writing Z:\Content\Images\Renders\someimage0005.TGA" but no images at all I guess this is the problem.

Hope this helps.


07-20-2007, 02:38 AM
The message files are the .enu files. These seem to hold all the message strings used in the program. If you mix up the .enu files from 9.0 with 9.2, for example, you'll get strange problems :)

So..you need to have the .enu files in the same folder as the executable for the error to go away. This is independent of your config file set-up.

As for the file writing thing, this is an immensely irritating issue with LWSN. It claims to write the file, but where it encounters a problem, never notices. It just lies through its teeth about saving images. It's frustrating - I'd rather have the node stop dead in its tracks than chew through frames without saving them.

Mr Maze
07-20-2007, 11:08 AM
Well, all of the paths are correct in the nodes that aren't writing files. They have access to the render folder and the same config files as the other nodes. They also have correct network access to all of those places...

All of the ENU files are on each computer in the same folder that LWSN executes from. Hmmm.... Should I try having all of the executable files on a shared network folder so that there are not different versions of them on each machine?

I think that I found the most annoying thing is that those nodes say that they are rendering and the controller thinks they are, so instead of them saying DAHR I can't do it so that the controller hands off those frames to another node you end up with unrendered frames all over the place.

Chepe: it apears that your runner program only shows up one node on my dual core machine; do you have to open two instances of it just like with manually configuring nodes with a .bat file?

07-21-2007, 11:18 AM
It is best to install LW on a shared drive, maybe you want to try a new LW installation.

Before doing this, try to find duplicate config files or wrong config files. Also, if you are working with 9.2 try to render to the content dir.

You do not need to open 2 instances of Runner just set "Total nodes" to 2, on the bottom of the window you will see the resulting nodes numbers: Node # 5, Total Nodes 2 = nodes 5 and 6.

Mr Maze
07-25-2007, 10:24 PM
Thanks Chepe

I haven't had time to take another look at it but just having those 4 nodes up and running has been a big help. I will have some animations that I am working on that will need to be rendered here in the next month (3d work is not all I do at my job) and will be looking at getting those other nodes working proper as soon as I can...