View Full Version : 8.5 Texture Displacement question

06-28-2007, 07:01 PM
Will anyone still using LW 8.5 please help me figure out why Texture Displacement does NOTHING? I have two layers in my texture, both in the Color Channel: Layer One is a standard Veins procedural, set to Normal, and layer Two (underneath layer One) is a standard Turbulence procedural, set to Texture Displacement.

According to the docs, this "should" alter the standard veins texture. But it is doing NOTHING. I must be forgetting something REAL simple, hopefully. I've made sure that if this was working properly, that each layer is of the appropriate color, size, and contrast, to be effective. But still :confused: no joy.

Can someone please tell me why this isn't working?


06-28-2007, 07:29 PM
Just to make sure this issue isn't something weird with my configs, I used a month-old backup set, hoping this would make the difference. But ... NOPE. :-(

06-28-2007, 08:02 PM
Hmmm ... started from scratch with an entirely new object as a test, and it works FINE.


So now I have an entire SERIES of corrupted objects. Three days down the tube. :-(

What can I do about this? Get my text editor out and search for some kind of obscure errors in the object files? <sweating bullets here>


06-28-2007, 08:12 PM
So far, I did try a text editor. Forget that. I might as well try to read ancient Egyptian.

I typically do texturing in Layout, using the Hub to switch between Layout and Modeler, specifically to save files, then updating Layout and returning to it. Is there some kind of known bug with this workflow? (LW 8.5)

I tried opening one of the many apparently corrupted object files directly in a fresh Modeler, but it did not help. Texture Displacement simply FAILS to work in every one of these object files, whether in Layout or Modeler.

I am sunk.

06-28-2007, 08:33 PM
Worst news yet:

I thought maybe I could go to the earliest model, before ANY texturing was done, and laboriously copy/paste dozens of texture layers into the old model, as a way of beginning to restore these models.

But even the VERY FIRST model does not allow Texture Displacement to work.

So I am truly SCREWED. -- unless one of you geniuses knows some kind of trick to fix this problem.

Thanks for ANY advice ...

06-28-2007, 08:53 PM
I also tried deleting ALL the textures from an existing mesh, saving the mesh as a NEW object file, then starting from scratch on the texturing.

But Textured Displacement is STILL not possible on any of these files.

What can I do??? Please??? Someone???

06-28-2007, 09:26 PM
Havent had this problem. Can you upload one of the objects?

06-29-2007, 01:45 AM
This is apparently a BUG, and I found a workaround. (whew!)

It all has to do with SIZE.

My objects were averaging about 500m in height. Believe it or not, this was the problem with Textured Displacement not working! All I had to do to get these objects to work properly in texturing was to reduce them down to about 2m in size, and reduce the texture sizes proportionately.

VOILA! Textured Displacement works fine.

You can prove it to yourself by making any simple object (such as a sphere) at a 500m size, attempting to texture it using Texture Displacement. It will NOT WORK. (Does this work ok in 9.2, btw? This bug is in 8.5, for BOTH Layout and Modeler.)

Then take the same obj and size it down at 0.5% (to 2.5m) and reduce the texture sizes as well, and Textured Displacement works fine.

Don't ask me why. It's a BUG.

06-29-2007, 03:18 AM
well it works but you have to push the layer opacity to very high numbers (10000) to have the desired effect. Strange!
(Lw9.2 Pr1 latest beta)