PDA

View Full Version : 9.2 Menus and Prefs not sticking



safetyman
06-22-2007, 06:31 AM
I've searched the forums for the answer to this, but come up dry (maybe not searching for the right thing). I've been using 9.2 for only a little while, but now all of a sudden, every time I open modeler, all the menus I've set up and the preferences all go back to default. None of my settings have been saved.

I have 8.5, 9.0, and 9.5 all on this computer. Could that be the problem? 9.2 reading 9.0 settings somehow? I thought I had removed all the old configs "away" from 9.2. Please help!

v1u1ant
06-22-2007, 10:18 AM
have you entered the new paths to your config files in cmdline?

having all the apps (8, 8.5, 9, 9.2) shouldnt be a problem as i have all of them on two machines now and they both run fine.

safetyman
06-23-2007, 07:10 AM
I had edited the cmdline before -- maybe I typed something wrong. I'll try again and let you know how it goes.

safetyman
06-25-2007, 05:46 AM
Still not working. I would guess that version 9 menu configs are somehow interfering with my 9.2 setup. Any suggestions?

safetyman
06-26-2007, 05:20 AM
Any 1?

Dan_NT
06-26-2007, 08:37 AM
9.0 and 9.2 do use the same named pref files, if you want to use the two simultaneously you could go into Hard Drive > Applications > NewTek > LightWave 3D 9 (or 9.2) > Programs. Inside of there we will edit two files inside of TextEdit: Modeler CmdLine and LightWave CmdLine. Both files will contain the exact same command:

-c"hard drive:path:path"

Just a hyphen and the letter 'C' (not case-sensitive) followed immediately by the path on the hard drive where you would like the new pref files to be saved to in quotations.

Now just make sure to go to File > Save and you can close the CmdLines and open up Modeler and Layout now and they should write their pref files to the directory you specified and not conflict with the other install of LightWave.

I will also note that it is not necessary that you keep 9.0 after installing 9.2 as the new install is not dependent on the old directory in order to function. It is thus a stand-alone install, so if ever you need to reinstall don't worry about using your original CDs, just download the 9.2 setup. You can also choose to keep 9.0 and 9.2 on your system and they won't conflict aside from this minor issue here.

safetyman
06-27-2007, 09:44 AM
Thanks for the reply, Dan. However, I don't see the two "CmdLine" files you pointed out. Do I make them? If so, what type of file are they (.txt or .cfg or what)?

Perhaps I forgot to mention that I'm using a PC. Sorry to be such a pain, and thanks again for all your help.

m.simpson
06-29-2007, 09:21 AM
I had the same problem, but this is how I solved it on my machine.

1. created a new directory to store new 9.2 config files.

e.g.

c:\lwconfig92


2. amended the shortcuts as follows:

* start > all programs > Newtek > Lightwave 3d 9.2 > now right click on modeller and select properties

* For Modeller change the target shortcut to

"C:\Program Files\NewTek\LightWave 3D 9.2\Programs\modeler.exe" -cC:\lwconfigs92

* For Layout change the target shortcut to

"C:\Program Files\NewTek\LightWave 3D 9.2\Programs\layout.exe" -cC:\lwconfigs92

Notes: if you create a directory name with spaces in the name then you must surround the path name with quotes e.g -c"c:\lwconfig 9.2". Also note that if you were to run modeller now it will create default out of the box config files, so you would have to set everything up from scratch again - plugins, content directory and shortcuts.

3. What I did was to copy the 9.2 config files into the new directory.

* copy and paste LWM9.CFG from C:\Documents and Settings\[username] into the new directory e.g. c:\lwconfig92
* copy and paste LWEXT9.CFG from C:\Documents and Settings\[username] into the new directory e.g. c:\lwconfig92

In notepad open LWM9.cfg in the new directory and change all 9 references to 9.2. For example with the preset problem I changed the line

PSPresetsRoot C:/Program Files/NewTek/LightWave 3D 9/Programs/Presets

to

PSPresetsRoot C:/Program Files/NewTek/LightWave 3D 9.2/Programs/Presets

Of course change the directory name to match your installation directory.

4. Run Modeller and everything should be good.

safetyman
07-03-2007, 05:28 AM
Thanks for the help. Unfortunately, all the methods I tried did not solve the problem. What I had to do was uninstall LW9, which solved the problem. I don't really understand why none of the methods worked for me, but I appreciate all the help. Thanks again.