PDA

View Full Version : Refraction question



monovich
06-04-2007, 12:30 PM
I've got a refraction problem and I'm not sure how to solve it.

I'm shooting "through" a mesh that has refraction qualities. Every object with transparency seen through the mesh seems to inherit those refraction qualities even though they have refraction indexes of 1.

I'm trying to put reeds/kelp in the water and am using transparency to mask the transparent/opaque areas of the object, but it's ending up looking wrong because it has refraction in it's transparency. Grr!

If I turn off "ray trace refraction" then the problem goes away, but I want refractions.

I can't use clip maps on the reeds because they are semi-transparent in areas.

Any ideas? I tried using "Additive Transparency" but it exhibits the same problem.

This is such a simple thing to want to achieve, but I can't find a way to make it work.


See the examples below for refrence. The first is sans refraction, the second has it on. Notice the screen of the squid distorting and obviously the kelp is totally buggered.

monovich
06-04-2007, 04:10 PM
man, I'm 0 for 2 on my questions today. Has nobody run into this?

UnCommonGrafx
06-04-2007, 04:21 PM
Try to turn your ior down to something below 1 for those things you are masking. In the past, that was 'fix' for some of what you are describing.

jameswillmott
06-04-2007, 05:33 PM
The IOR for the transparent parts of the kelp has to be the same as the water, then you won't get any refractions.

monovich
06-04-2007, 07:58 PM
ah! setting them to the same IOR worked. Thanks so much. You saved me tons of time because I was going to have to re-build it another way.

:)

jameswillmott
06-04-2007, 08:10 PM
Happy to help!