PDA

View Full Version : UV Map Texture distortion.



sculptactive
06-04-2007, 05:34 AM
I am guessing that this is not 9.2 related, but its could be. I seem to be having one of those days when I cannot "see the wood for the trees".
Can someone please put me out of my misery.

The Model is set to subPatch. The UV Map is set to SubPatch, yet the texture is still distorted at the edges.

MooseDog
06-04-2007, 06:05 AM
does it render like that too? opengl is not always a 100% faithful representation of a render.

also try moving the vertices in uv space so they are less "distorted" and more straight across and up-n-down. should be easier to paint on a tree texture (i'm geussing that's what that is :) ).

sculptactive
06-04-2007, 08:28 AM
Thanks for the suggestions MooseDog.

Its strange. I don't remember this happening pre 9.2 with this model, but I have taken previous versions of my setup so I cannot confirm.
Then again, I could simply be missing something really basic, just having one of those days.

Moving the vertices makes the problem less noticable but if you look closer it is still there.

Rendering, sadly in this case makes no difference.

Dodgy
06-04-2007, 08:51 AM
Do you have two sets of vertices in the same place in UV space, but different places in objects space?

sculptactive
06-04-2007, 09:21 AM
Do you have two sets of vertices in the same place in UV space, but different places in objects space?

That would make sense but I dont believe I have any. The attached pic shows only 1 vertice on the object space .


If I turn off SubPatch and subdivide the texture is perfect. There is no distortion.

mkiii
06-04-2007, 01:44 PM
Try adding another loop of edges just above the bottom of the main chunk, roughly the same distance from the edge as the narrow band at the bottom.

IE make it 2 narrow bands instead of one.

Trev.T
06-04-2007, 03:35 PM
Have you tried setting the UV map to discontinuous edges?

sculptactive
06-04-2007, 04:05 PM
Try adding another loop of edges just above the bottom of the main chunk.

Adding more edges has the same effect as moving the vertices closer, it makes the problem less noticable but if you look closer it is still there.




Have you tried setting the UV map to discontinuous edges?

No joy with discontinuous or subpatch.

mkiii
06-04-2007, 06:14 PM
In that case, have you tried scaling the outer edge points of the smaller round part out a bit, or alternatively, scaling the inner points of that part down a bit.

sculptactive
06-05-2007, 03:58 AM
mkiii thanks for the suggestions.

A combination of scaling the outer edge points and adding more edges has made bit a lot better.