PDA

View Full Version : nodes no-no



Zibi
05-30-2007, 02:42 AM
OK I shouldn't have done it but I started a commercial project using 9.2 as I thought it might be quicker on the render times. I also decided to use nodes for the first time because I saw a tutorial on making a double sided surface (wrapping paper) have a different material on each side.
-I got the nodes setup and it all works fine, even rendered out fine.

Phew!

However I discovered a little glitch in the node editor which is worth knowing.
A number of image maps I was using for reflections and specularity etc. needed to be inverted from the originals. Clicking invert in the relevant panel of the node editor, simply makes it become blank. So I figured the workaround would be to duplicate the image in image editor and invert the duplicate

-This worked fine and I was using several textures in this manner.

But on saving, to my dismay I found that the duplicate images are lost from the shader. Same thing if you try to save it as a preset, or even jump into modeller.
The only workaround I could figure was to make an inverted texure in photoshop and load each image independantly.

This was the case with the mac, I have yet to test it on the PC -don't have time till this project is finished.

LW 9.2
G5 OS 10.4.9
Dual 2gig
2GB RAM
ATI Radeon 9800 pro

Weepul
05-30-2007, 05:35 AM
However I discovered a little glitch in the node editor which is worth knowing.
A number of image maps I was using for reflections and specularity etc. needed to be inverted from the originals. Clicking invert in the relevant panel of the node editor, simply makes it become blank.
That's not really a glitch, so much as it is a confusing naming scheme since it uses the same term to do something different. In pretty much all nodes, the "Invert" checkbox switches the foreground and background. In an image node, if opacity is at 100%, that means that instead of seeing the image, you'll see the node's background color.

To invert an image the old-fashioned way, you can set the node's background color to white and change the blending mode to Difference.

Zibi
05-31-2007, 01:50 AM
cheers for that.

-That pretty much makes the problem irrelevant.

:D