View Full Version : Memory problems in 9.2

05-24-2007, 05:47 AM
I have a large scene that I made in 9.0, when I load it in 9.2 I run into some "out of memory" errors. If I check my task manager, I can see that I have more than 800Mb RAM free. This seams a little strange - and very anoying.

I'm on Windows XP Pro SP2 on a DELL XPS M1710 2Gb RAM.

05-24-2007, 08:02 AM
I have the problem too. I Have a more than 2Gb Ram. the render in Fprime stop or Layout is Close...

05-24-2007, 08:10 AM
If it's failing at render time you might try rendering it with VirtualRender that will be released shortly.. http://www.newtek.com/forums/showthread.php?t=68507&highlight=virtualrender

I also read recently about problem with loading too big images, at scene loading time, image loader took twice as much memory as needed for very demanding 8k maps.. but after successful loading it dropped to normal memory usaged.. In that case try changing image to different format f.e. BMP, and if it does not help, changing 32 bit image to 8 bit, to see whether it helps.. If yes, some image optimizations will have to be done, or InfiniMap used instead of LW image editor..

05-24-2007, 09:38 AM
Won't fix the problem but might be a workaround.

Google for "xp sp2 /3gb switch"

When used it allows XP 32 bit to access more than 2 gb of ram - up to 3.4 - 3.6 gb depending on motherboard design.

Typically XP's background memory useage gets moved into this area leaving the lower 2 gb + for apps.

Results can vary.

Also - setting virtual memory to min/max of around 3500 to 4000 might help in some case.


05-24-2007, 10:11 AM

Im getting FPRIME closing during render too - seems random - after a couple hundred frames or so.

5 GB of mem left - 9.2 32 bit running on XP64.

DOes it seem random to you? Does your shut without errors?

I`ll try the xp sp2 /3gb switch -

05-24-2007, 11:11 AM
If you're running 64 bit you shold already ber able to access more than 4 gb.

If the 64 bit version is having problems with 5 gb of free mem then the problem must be a MASSIVE overload of data input during loading.

Granted XP 32 bit isn't that great or accurate regarding either memory reporting or management but 64 bit seems to be a bit better.

Of course there's always a possibility of external influences causing the problem.

How wide spread is it?

Does everyone experience it?

Can someone come up with a test scene that causes the problem consistently? I'm not saying post some your work - just a generic test scene that has the type geometry count and image map file sizes that cause the problem.

That will help two ways -

1 - it will help determine if the problem is consistent

2 - Newtek can look at what's happening in a controlled environment. Providing such an example would be better than saying 'it crashes with laarge scenes and image maps' By analyzing the particukar scene components it may well help find the cause.


05-25-2007, 02:13 AM
In my case I have a scene with a lot of objects in. I can load any of these objects into a scene one at the time without any problems. But if I try to load my large scene there all the objects are in at the same time, and many of them several times, I get the out of memory problem, and that's while the task manager shows 7-800 Mb of free physical RAM.

So in this case adressing more than 2Gb of RAM shouldn't be a problem.

The scene worked fine in LW 9.0.

It seams like LW has it's own maximum RAM available ?!

05-25-2007, 08:52 AM
Yes the 3bg switch has not helped...as you say xp64 handles memory different - when I went to make the change I realised that but carried on anyhow.

Im having to continualy render the scene - eventually it will be rendered - if I can make a dead scene to post it will take some time - hopefully someone has one handy.

05-25-2007, 11:15 AM
Han, The Layout is closing when I use objects with mapping UV.

05-25-2007, 12:08 PM
Are you using the PSD export plugin? that one eats memory like there's no tomorrow. Rendering with another component output plugin or just in stages will allow you to go much higher in resolution and detail.

05-25-2007, 03:16 PM
same mem prob here

05-25-2007, 03:40 PM
Raad mines got everything with UVs. 1.6 mil polys 151 image maps spread over 288megs of images (mostly 8bit indexed)

I dont get the mem error but the symptom of layout closing randomly seems the same.

Im trying to gain access to thte beta forums - hoping to find more info out there as this part of the forum is a bit of a information dessert.

Does it not close when you render it in f.e. 40x30 resolution, LW92 ACT Perspective Camera?
If it's working, not closing Layout, at such low res, it'll be rendered without problems with VirtualRender.. http://virtualrender.trueart.eu

05-26-2007, 07:43 AM
288 megs of images? Can they be compressed more?
I remember reading that LW will use about 10 times as much RAM to render as there is in each image. In other words, a 1 MB image file will use 10 MB RAM at render time.
288 MB's would be 2.88 GB.
Assuming I didn't read that wrong, that is - I think I got that from LightWave 3D 8 texturing, by Leigh van der Byle.

05-26-2007, 08:09 AM
I never heard that X10 thing before - I hope its not the case cause 300megs of textures is often required.

05-26-2007, 08:19 AM
Well memory usage for images can be a little deceptive. The images need to sit uncompressed in memory it doesn't matter how small you get the file on your harddrive, it takes up the same amount of ram. a 2k x 2k bmp that's 50meg on disk takes up exactly the same amount of memory that a 2k x 2k jpg that's only 1meg since their both 24bpp and have the same resolution. (numbers are just made up)

The way you save memory with your textures would be to convert grey scale images to a greyscale format (a 16 bit floating point EXR is smaller than a 24bit jpg, and is HDR to boot) or to use palletized formats.

Also make sure you're not bringing in a format with channels you're not using. Don't save a file as a 32 bit TGA if your texture doesn't need an alpha channel. That would be 25% wasted memory consumption on the image right away.

05-26-2007, 08:35 AM
That's interesting, Extent, I didn't know that.

Han, I know I read that somewhere, just can't be sure where. i'm searching that book to see if that's where I got it from.

In any event, the surface editor displays memory usage for each surface, I believe.

05-26-2007, 08:53 AM
Yeah, in LightWave 3D 8 Texturing, by Leigh van der Byle, published by Wordware, Chapter 11, page 210, 4th paragraph, she writes, An image's size in megabytes will use approximately ten times that amount of system memory when used with LightWave

Is that correct?

05-26-2007, 09:04 AM
I get memory overloads with only a single 16bit 20K tiff and 1.5 million polys being deformed by six bones. It usually happens with the PRMBlur so I'm not sure if that's overloading my memory or not. I have 2.5GB of Ram and according to lightwave it was only a 300MB scene or less for most frames.

05-26-2007, 09:26 AM
LightWave might tell you 300Mb in the render status window, but task manager tells the truth :) (as covered in that other thread).

The Task manager did say that I had Ram to spare. The problem usually happens during a F10 render sequence not a F9 anyway. An F9 always works so I really don't know what is going on under the hood.

05-26-2007, 09:39 AM
Sounds like not freeing memory somewhere.. after rendering couple frames, it's starting to be significant and you can't render anything.. Something like that?

05-26-2007, 10:15 AM
Sounds like not freeing memory somewhere.. after rendering couple frames, it's starting to be significant and you can't render anything.. Something like that?

Yeah. something like that but I forgot to say that this problem only happens when using "Per Polygon level" when using PRMBlur in the scene that I'm testing. Since I don't know how PRMBlur utilizes memory, I'm pretty much lost on this case. Here's the fog bugs case I issued with the scene file at the bottom.


05-26-2007, 11:22 AM
I just ran into this problem too. And with a VERY simple scene.

I threw together a quick scene just to help teach myself about the new AA and Radiosity tools. I used NewTek content objects, just a real quickly thrown together scnene.

Here is a screenshot:

Here is my scene file:

57,191 polygons, 8.53Mb used, aaaaaand it ran out of memory during rendering.

This error appeared even after restarting my PC. This happens on the first attempt at rendering.


05-26-2007, 11:33 AM
Oh my God.. you set GI minimum evaluation space to 7 micro meters.. And you have scene big 30 meters.. What do you expect in that case?

05-26-2007, 11:39 AM
oh boy. see, I was just trying to learn the new tools.


05-26-2007, 08:42 PM
StevenDS, how much RAM do you have?
I ask that because I downloaded your scene and started it rendering. I had an object open in Deep Paint 3D with several hi-res textures (plus I have my memory allowance for the undos set to 80 MB), and a Word document wit pictures I've been making into a PDF document.
Out of the 2 gigs of RAM I have, that left 650 MB available when I loaded your scene.
I started rendering it and the RAM count slowly went down to 1 MB, but back up and hovered alternated between 8 MB and 14 MB. It continued doing that until I aborted the render at 23%. I have no reason to believe it wouldn't have finished.
I'm on a PC too, btw, with 2 gigs RAM, Win XP Pro, SP2, and an Intel 3.2 ghz CPU.
LW 9.2, obviously.

Have you tried setting the render segments to something higher than 1? That way, it'll render the image in segments, using only as much RAM as it needs per segment.

05-26-2007, 10:25 PM
IMI, set minimum evaluation space to 1mm and if your CPU is dual-core, you will see it in 2 minutes..