PDA

View Full Version : Alternates for Vertex Loader?



Ma3rk
05-18-2007, 12:44 PM
I tried using Vertex Loader today on a scene done in LW 9.2 and it simply doesn't do anything. Older scenes (i.e. Classic Content examples) seem to work fine.

D-Storm's Load Bones plug-in isn't working in 9.2 either.

Any alternatives in the mean time?

Thanks,

M.

Dodgy
05-18-2007, 03:40 PM
Because the scene format changed, these plugins won't work with them. However, if you export the scene as a 6.0 scene (just save it under scene6.lws or something), then try them, they will work.

Ma3rk
05-19-2007, 12:33 AM
I tried that earlier but w/o much luck. The object needs to be converted as well it seems, etc.

Vertex Paint still works, but that doesn't help much if you've made changes to the objects bones in Layout as the Skelegons no longer match which is what VP works with.

Oh well. The whole bones & wt. mapping toolset needs to be reworked anyway.

M.

Dodgy
05-19-2007, 05:02 AM
Bones loader shouldn't need the object in 6 format, all it does is read the scene file, so if the scene is in 6 compatible format, it should be able to read it perfectly. I've done it so I know it does work.

Ma3rk
05-19-2007, 11:03 AM
I'll give it another try today then.

M.

Ma3rk
05-19-2007, 11:35 AM
Nope. Just tried it again and no go. Modeler locks up the moment I try to open the the newly saved 6.0 version scene with Load Bones.

M.

Sensei
05-19-2007, 12:37 PM
??? Are you tring to load scene in Modeler? ;)

Ma3rk
05-19-2007, 08:20 PM
Well, that's the way Load Bonea works, at least from the few English words available in the docs:

Load Bonesをモデラ?[に登録するには?AModeler->Plugins->Add Plug-ins...ボタンを押して?A LoadBones.pを登録して下さい?B
Construct->AdditionalにLoad Bonesという?ニュ?[が表示されます?B

?記: Modeler->Interface->Edit Menu Layout...を起動して?ALoad Bonesを適当な?ニュ?[ 位置に配置して*ださい?

For the record, trying to import the 6.0 version of the scene with Vertex Loader crashs Modeler as well.

M.

Sensei
05-20-2007, 05:01 AM
Ahh.. It must be 3rd party plug-in.. Well.. Try running Layout v9.0 or Layout v8.5 and reading the file that you're tring to load in Load Bone in Modeler v9.2.. This way you will check whether it's really v5.6/v6.0 LWS.. It used to here sometimes not write correct version scenes and they remained in v9.2 LWS format..

It's easy to check this by yourself in text editor, v9.2 LWS has beginning "LWSC 4" in two first lines.. Conversion LWS by hand can be done by changing "4" to "3", and then removing the all "10000000" etc. values before LoadObjectLayer, AddLight and AddCamera..

Ma3rk
05-21-2007, 10:40 AM
I checked the 6.0 scene version header and it has LWSC 3.

I've already uninstalled LW 8.5. If I try to open the 9.2 scene in Layout 9.0, gives a simple message box that a newer version of Lightwave is required. If I try to open the 6.0 version of the scene in 9.0 Layout, it hangs at the prepearing geometry stage.

Both Load Bones and Vertex Loader crash in 9.0 Modeler attempting to import the 6.0 scene.

Guess I'll just wait until things get fixed.

M.

Sensei
05-21-2007, 10:53 AM
I checked the 6.0 scene version header and it has LWSC 3.

How LoadObjectLayer etc. line looks like?


If I try to open the 6.0 version of the scene in 9.0 Layout, it hangs at the prepearing geometry stage.

I used to have it too sometimes.. What happens if you open object in Modeler v9.0? If it opens it, try overwritting file on disk.. And then loading in Layout v9.0 this scene.. It should no more hangs on preparing geometry..



Both Load Bones and Vertex Loader crash in 9.0 Modeler attempting to import the 6.0 scene.

Apparently these plugins are not checking properly scene prior loading..



Guess I'll just wait until things get fixed.

Better contact author and inform about this issue..

Ma3rk
05-22-2007, 02:45 PM
I've tried every combo I could think of. Simply isn't going to work. 9.0 won't open or import a scene saved out from 9.2 as a 6.0 scene. It hangs at the geometry load step. I can open the 9.2 geometry in 9.0 Modeler and save it with a new name. I then tryed to swapping out the original 9.2 geometry in Layout 9.2 with the newly created 9.0 geomentry and saving as a 6.0 scene, but that scene also hangs when attempting to open in Layout 9.0.

Load Bones is a 3rd party plug written in Japanese and probably preceeded Vertex paint.

Vertex Paint & Loader on the other hand, although apparently written outside of Netwek, is incorporated in to the normal install of the program and as such the issues need to be addressed by Newtek.

My main question though: Who dropped the ball this time in Beta testing?

M.