PDA

View Full Version : LW 9 "Render Outlines" Freakout !!!



B_Free
05-10-2007, 11:43 PM
I really really hope somebody can tell me how stupid I am ...

:confused: I can't get my object's outlines to render! I have a 1 polygon ring. I just want the perimeter to render (preferably with a glow effect around it... but if needs be I won't be picky).

Here are some of my Object settings:
Surface Editor > Advanced tab...
- Glow Intensity = 50%
- Render Outlines = Checked

In Object Properties > Edges tab...
- Polygon Since = 100%
- Particle/Line Thickness = 5 pixels
- All the Edges are turned on

The camera Reconstruction Filter = Classic (I read somewhere that this might have something to do with it.)

8~ If I click off "Render Outlines" then the whole circle renders perfectly (complete with glowing edge), but the circle is also filled in. When I click "Render Outlines" on again... I get nothing at all.

Is there an additional setting or control in 9 that I have to set in order for this to work?

Additional Info:
My scene file was made in LW8; I never experienced this problem there.

Thank you very much in advance!!!

LW 9 Build 998 -- OS X 10.4.9 -- PowerPC -- Dual 2.7 GHz -- 2 GB RAM -- 0 Clues

Castius
05-11-2007, 12:14 AM
perspective camera don't render edges yet. Switch to a classic camera.

brian.coates
05-11-2007, 05:09 AM
I can't seem to replicate this problem in 9.2.

I suggest upgrading. It's free.

B_Free
05-11-2007, 10:11 PM
I checked and unfortunately I am in Classic Camera. Thanks for the suggestion though Castius!

I'm therefore in the process of upgrading to LW 9.2.0... but I'm a little nervous because of what I've read in some of these other threads.

Is there a specific folder where I need to place the "Relativity" folder in order for it to work?

Thank you very much!!!

B_Free
05-11-2007, 11:00 PM
:bangwall: ARGGHH!!!!!

Okay, now I'm just getting depressed.

I installed Lightwave 9.2.0 and the problem is still there. So...

I tried going back to Lightwave 8.5 (which I still have installed on my computer) and opening the file. Now it doesn't work in 8.5 either!

I started thinking maybe something is just wrong with my file.
I cleared the scene, opened a random object in layout, and tried to render the outlines. It didn't work.

If I uncheck the "Render Outlines" box... then the object shows up.
If I check the "Render Outlines" box... then the object is not rendered at all.

Does anyone have any more ideas?

Thank you!!!

brian.coates
05-12-2007, 01:21 AM
Is your polygon's surface single sided?

If so, try flipping the poly so it's facing AWAY from the camera. That way all you can possibly see is the outline.

BTW, if you need to use a v9 scene file in v8, you need to export it as a v6 or earlier file format - v9 scene files have extra info in them, (due to new features) that cause earlier versions of LW to freak out.

As a last resort I'd try scrapping your config files and building new ones from scratch. Usually fixes 90% of problems that I have. I'd suggest exporting your menu layout and keyboard shortcuts for Layout and Modeler first though, since setting them up again is what takes the most time when making fresh configs.

B_Free
05-12-2007, 09:32 PM
I'm afraid I owe everyone an apology.

It looks like the problem is in the surface I was using for the object. I don't know what happened, but when I used a different surface and clicked "Render Outlines" the outlines started showing up again.

I guess the real problem is that I used the same object & surface in my testing that I used in my problem scene. Since all the objects & surfaces had worked before I automatically assumed the problem was in the program. I didn't even consider that the objects or the surfaces could have become corrupted like that. I guess this'll learn me. :foreheads

On the bright side, I learned way more about Config files than I ever knew before! Thanks for that Brian! :)

Thank you very much everyone!!!