View Full Version : "Legacy GL" button doesn't stay on in 9.2

05-09-2007, 05:16 PM
Howdy! Having fun with 9.2--good stuff!

While in the middle of building my new desktop, I've been working on my laptop and I noticed GL redraw issues in Modeler. I look in Display properties, and I notice a nice "Legacy OpenGL" button. This takes care of all my redraw issues I was having--nice!

The problem was when I exit modeler. The button is toggled off after I restart Modeler.

Is this a known bug? If so, yahoo! I've alredy checked my LWM9.CFG and such to make sure cfg files weren't being write protected.

Anyway, don't mind toggling that button on every time I start for now.

05-09-2007, 06:59 PM
Have you tried geometry acceleration set to bufferd VBO, uncheck legacy ogl(that is the old way) sort by object, multitexture shader and uncheck every thing else. The button thing is driving me nuts too.

05-09-2007, 09:15 PM
well, truth is, I'm on a FX5200 mobile... talk about Legacy! I had turned all the GL 'bling' off but still I had redraw issues. Anyway, at least Modeler works--just wish it would stay toggled on.

John Jordan
08-19-2007, 03:06 PM
I am having the same problem (with the same NVIDIA video card) but in a desktop PC.
Tried updating the drivers and although NIVIDIA claims compatibilty, it just isn't so. I want to work with my app, not constantly ON it.

I recently upgraded to LW 9.3 and immediately started having problems in Modeler. Aside from display problems, if I go to 'textured wireframe' it locks up my entire system necessitating a reboot.
Checking the legacy box solved the problem but it won't remain toggled on.

9.3 seems to be a nice update (and I was skeptical before installing it) but I'm not going to run out and buy a new video card just for a point upgrade. And if I can't use my chosen product without workarounds, what's the point?

How about someone from the company addressing these concerns on this board. Surely someone there can tell us how to keep the legacy button checked.

John Jordan
08-19-2007, 05:41 PM
In the Display Options box I changed "Geometry Acceleration" option from "Buffered VBO" to "Streaming" and the display irregularities seems to have disappeared. Hopefully the crashing will cease as well.

:thumbsup: JJ

08-20-2007, 06:30 AM
Yup, for the likes of FX5200 cards you need to do that. Had similar problems myself until I switched to 'streaming'.

09-07-2007, 11:32 PM
Oh! Thank goodness, this has been driving me nuts since 9.2

11-22-2007, 03:43 AM
and yes, the originally reported bug is still persisting in 9.3.1! posted to keep this alive (and hoping it will get fixed once)...