PDA

View Full Version : Help files



mwh710
05-09-2007, 01:21 PM
I have upgraded all of my computers (lab of 32) to 9.2 & I am reasonably happy, but I & my students now need the help file that should have come with it. I found where you have to download it separately, but after the file is unzipped, I get a package is corrupt error. I tried several times. What gives? Am I the only one?

Chilton
05-09-2007, 02:10 PM
Hi,

It's not just you. New docs for the Mac version will be available shortly.

-Chilton

mwh710
05-16-2007, 09:08 PM
Any idea when "soon" is. It may be trivial to a lot of experienced LightWavers, but I have a slew of just learning students & "help" well... helps....

Chilton
05-16-2007, 09:33 PM
Hi,

I finished the conversion from Flash to a format more palatable by the MacOS X Help system today, and will be working on the installer for it tomorrow.

These docs just 'plug in' for the UB version, but that's something you'll have to join the Open Beta to experience ;-)

-Chilton

mwh710
05-17-2007, 05:49 PM
I hope NewTek knows what a "find" they have in you. Thanks... - Hey Newtek, give the man a raise.........

mwh710
05-29-2007, 05:19 PM
Hmmm still no Mac help files..... :(

Chilton
05-29-2007, 06:04 PM
I'm not sure what happened to them. I'll find out tomorrow when everyone's back in the office.

-Chilton

mwh710
06-05-2007, 05:51 AM
I know that it may be pretty small to some, but to a group of student, Help Files become important, especially with finals looming over their head. I keep hearing that they are done, but they're not up on the web site.... What gives?

Chilton
06-07-2007, 08:45 PM
Hi,

The docs are now updated online. I look forward to your feedback. I see that it still says they're the old ones, but they're not. Download them and try them out!

-Chilton

v1u1ant
06-08-2007, 03:41 AM
where are they located i cant find the URL.

v1u1ant
06-08-2007, 04:06 AM
OK sorry im asking silly questions again, of course i know where to download the help files.
Ive been and done it.....but when trying to expand the zip file i get an "unable to archive' error message

mwh710
06-08-2007, 07:34 AM
.dmg is still corrupt. I tried 4 X's. It looks like the same old one is still up there.

gatz
06-08-2007, 11:33 AM
Ditto. Is it supposed to be a .pkg, a .dmg or a .zip?

rg

Chilton
06-08-2007, 12:02 PM
Zipped pkg. it's working here. Doh!

-Chilton

mwh710
06-08-2007, 03:49 PM
It downloads as a .pkg.dmg.zip. It unzips fine, but the .dmg is corrupt. I even deleted the .dmg from the extension and changed it from the image mounter to the app installer that gave me a package icon, but it did nothing, still no help files for a very expensive program. Very sad.... :(

v1u1ant
06-13-2007, 07:54 AM
yup im getting the same thing here aswell, downloads fine but try opening it and i get told its corrupt. tried in several different Macs here all stonking quads with OSX latest all give the same result. File is corrupt.

So.............not a big job surely would be good to sanity check this alongside your UB development.?

Chilton
06-13-2007, 08:01 AM
It's working here absolutely fine, which is why this is so frustrating. I'll see if there's something else we can do.

-Chilton

dsol
06-14-2007, 09:06 AM
It might be an issue with the unzipping process. Are you unzipping the files using OSX's built in Zip handling, or do you have Stuffit Expander (or similar) installed that might be hijacking the .zip filetype?

Chilton
06-14-2007, 09:40 AM
Hi guys,

It appears there are some server side issues that have been getting worse on this part of the equation. I will see if we can have them resolved today.

-Chilton

mwh710
06-14-2007, 08:19 PM
Ok, so Help downloaded & gave me a .pkg and it said that it installed, but when I try to use it, both Modeler & Layout say that it is not installed. Give me a hint as to what the file is called so I can do a "find", and where was it supposed to be installed? This is crazy.

AND.... Now when I open Layout, I get an error message - see attached. I have never gotten this before...:)

Chilton
06-14-2007, 10:32 PM
Hi,

In /Library/Documentation/Help/, there should now be a MacOS X Help file called LightWave.help. Open that.

It should have installed a simple html page that redirects you though, into your 9.2 directory. It sounds like it did not.

Regarding your newest problem, I eh... don't know what that means. I'll find out tomorrow though!

-Chilton

mwh710
06-15-2007, 09:32 AM
Here is what I see:

1) error when opening Layout
2) OSX/Library/Documentation/Help
3) Lightwave.help info
4)When I double click Lightwave.help
5) What I get when I try Help in Modeler or Layout

mwh710
06-15-2007, 09:38 AM
Here is what I see Cont...:

6) After saying yes or no to on-line help - I can click on every link & it goes to a page, but if I click on Table of Contents, it immediatly crashes

9) If I open & see package contents
8) If I dbl click Lightwave_Help.htm
7) Source code of Lightwave_Help.htm


I hope this help find out what is not hooking up right.

Chilton
06-15-2007, 10:22 AM
Here is what I see:

1) error when opening Layout

I think this is an unrelated issue. I'll see if I can figure that out too, though.



4)When I double click Lightwave.help


I've also seen this, but only on Panther. It doesn't happen here for whatever reason. But the trick here is to keep it all in the Mac OSX Help app. So close the browser window and go back to the Help app, and use Help from there. The search function should work well, much faster than the old Flash Mac system.

-Chilton

mwh710
06-15-2007, 11:47 AM
That's fine, but it crashes when I try to chose the Table of Contents,and How to get the Help feature to go to Library/Documentation/Help from Layout & Modeler, they want to go to the documentation folder inside the Lightwave folder..

Chilton
06-15-2007, 12:31 PM
Oh, the MacOSX Help app crashes? That's not good. It's just HTML! Bah, I'll take a look.

The big issue here is that this is the format the help file will be in on the Mac going forward, because it will be part of the UB itself. This is a temporary fix, until the UB is ready. For the time being though, it has to stay in the Documents/Help folder in order to run. Thank Apple's over-zealous security measures for that.

-Chilton

MysteryMonkey
08-06-2007, 08:21 PM
. . . For the time being though, it has to stay in the Documents/Help folder in order to run. . . .

Well I have been having troubles getting the help files to be accessible from within Layoout v9.2. I've tried the fix suggestions but still no luck. It just doesn't want to work. Probably operator error (maybe that I'm on an Intel Mac using PPC LW installation) but I have however been able to piece together my own temp fix. Unfortunately I can't do a word or phrase search but I can read through the help features.

Here was my solution after running the install.

1. Command + F to search the system for "lightwave.help"

2. In the found window Control + Click on "lightwave.help" and then "Copy" the file.

3. Click on the Desktop then Command + V to paste the file onto the Desktop

4. Control + Click on the "lightwave.help" you just pasted on the Desktop and then choose "Show package contents".

5. Find the "LightWave_Help.htm" and Control + Click on it. Choose "Make Alias"

6. Drag the "LightWave_Help.htm Alias" onto the Desktop.

7. Do not throw away the Desktop lightwave.help file.

8. Double clicking on the "LightWave_Help.htm Alias" will open up the 9.2 Help Files in a web browser.

Not very elegant. Kind of a crude solution and as I said I can't search the data base, BUT at least I have access to the help files for now.

That's my solution. I can hardly wait for the time when this little glitch gets worked out.

keniarts
08-07-2007, 10:57 PM
I lost my help files when I upgraded from 9.0 to 9.2 on my PowerBook several months ago. I finally found them today, although through a wierd process.

I did the download and went to my docs folder in my library. I couldn't find the file. So I did a search in Spotlight. It saw the file there, so I looked again. Nope. So I went back to Spotlight and doubleclicked on the file from there. Bam! It opened.

Kinda Screamernetish, but it works.

CBronson
08-16-2007, 07:38 AM
I've downloaded the help files and after installing them I get this message.

"The Online Help Files have not been installed.

You can download them from the NewTek online registration system at http://register.newtek.com"

I wonder if its faster to ask on the forums what we actually need help with rather than trying to get the help files back. ;) Any suggestions?

Chilton
08-16-2007, 09:30 AM
Hi,

Open the /Library/Documentation/Help/ folder and double-click the LightWave.help file. The link isn't there thanks to a bug in the installer, which will be fixed soon.

-Chilton

CBronson
08-16-2007, 10:18 AM
Yeah I saw it in there, just wondering if there was a way to link it to the help button in the program so other people using it can easily find it. Cool that it will be fixed. Thanks.

MysteryMonkey
08-16-2007, 10:26 AM
Hi,

Open the /Library/Documentation/Help/ folder and double-click the LightWave.help file. The link isn't there thanks to a bug in the installer, which will be fixed soon.

-Chilton

I actually had to do a File Search to find it because for some strange reason if I went to the /Library/Documentation/Help/ folder it is would be empty. Nada, appears empty. However the File Search shows results and actually shows it in the /Library/Documentation/Help/ folder. Makes absolutely no sense to me at all, so that is why I've had to jump through a few extra hoops to copy and place the file/folder on my desktop so I can use it.

v1u1ant
08-23-2007, 12:37 PM
Ok i came back to this but i would like to just clarify. Oh im still on 9.2 UB.

the help files are located in library\documents\lightwave.help

So that means the link from inside modeler/layout no longer works because its not a flash based help file.
But because you were integrating the help files into the UB 9.3 version those links from the menu inside modeler/layout are now fixed.?????


is that right?

Chilton
08-23-2007, 01:03 PM
They should open fine in a web browser, but more importantly, they should work from the MacOSX Help system.

v1u1ant
08-23-2007, 05:45 PM
I can open the lightwave.help file which opens in the OSX help system yes.


But should they open from the help menu inside layout/modeler in version 9.3? Because in 9.2 they dont. I guess im asking if this is fixed in 9.3?

jproberts
08-29-2007, 09:54 PM
Just installed 9.3 UB on my Mac Pro. I can't access the help system but I was able to locate the lightwave.help file. It opens up fine when I double click on it. I'll just make an alias and leave that on the desktop for now. Is there any indication as to when this will be fixed inside of LW? Thanks.

Chilton
08-29-2007, 10:24 PM
A solid date, I have not. But this is on our list of things that will be fixed with a quickness.

-Chilton

jproberts
08-29-2007, 10:37 PM
Cool. Thanks for the prompt reply Chilton!