View Full Version : Kernel Trap, Cannot Boot

06-23-2003, 05:24 PM
This isn't exactly a Lightwave problem, but hopefully someone knows how to fix this.

I awoke my machine from sleep mode, then tried to hide LW Modeler, and I got a kernel trap. I know 10.2.x is not supposed to display the old-style kernel traps, and instead shows that international restart window. But, the kernel trap was the old-fashioned black with white text variety. Now my machine hangs at startup. All that is displayed is the apple and the segmented rotating disk. The machine will not progress beyond this point. I can't even open the CD to try and boot from the disc. The only add-on device I have is an iogear KVM switch, and i still cannot boot without it attached. I've also tried "command-option-p-r"(not sure if that can even help the problem i've mentioned here).

I appreciate any advice. Thanks.

06-23-2003, 05:44 PM
You can try booting while holding down the shift key. This will disable non-essential elements of the OS, and may allow you to boot.

As for the CD... try restarting while continually tapping away on the CD eject button (on the keyboard). I've always been able to get the CD to open that way.

When you boot up on the CD, don't forget to 'repair permissions' as well as repair disk. The disk utility is available on the upper menus (the file menu I think) when you boot off CD.

You may have to reinstall the OS. If you are running anything above OS 10.2, use the 'archive and install' option.

If things are really bad, get yourself a copy of Alsoft Disk Warrior. It's the best disk utility there is for the Mac, and they've just released a native OS X version:

06-23-2003, 06:42 PM
holding down the mouse button when you turn it on is the "by-the-book" way to open the cd tray

06-23-2003, 09:20 PM
I've attempted holding down shift. Doesn't seem to work in this case. And the superdrive won't open no matter what. I did get advice from another forum to try "command-S", which takes me to a very DOS-like interface. I have yet to figure it out, though.

Thanks for the advice. I hope I can figure this out without having to turn to the apple store.

06-23-2003, 09:53 PM
when you get to the "DOS-like interface" type:
fsck -y
that runs the self diagnostic/repair, run it twice.

06-24-2003, 07:58 AM
Once I've run fsck -y, is there a proper way to reboot, or do I just hit the restart button? I've tried running fsck -y once now, to no avail (g4 still hangs at boot), but hopefully the second time will do something.


06-24-2003, 09:04 AM
I've had this same problem on two separate Macs, running Disk Warrior fixed them both. Definitely a utility that should be on your shelf. DW has always come through for me.

06-24-2003, 02:23 PM
after fsck -y, I think you type "exit" to start up and "halt" to shut down.

I worked at a mac repair shop for a few months, and Disk Warrrior was constantly saving peoples a**es.

But I had a boot problem a month ago which DW couldn't fix, turned out to be a loose video card. You could try re-seating all your connections.

Will it boot from the CD? if you are getting to the command prompt, the tray should be accessable.

06-24-2003, 07:20 PM
When single user mode first starts up, i see "Couldn't alloc class NVDANV10HAL". Not sure if that's normal.

When I run fsck -y, before it "repairs" the drive, I'm told:
"Invalid volume directory count
(It should be 39030 instead of 38206)"

"Invalid volume file count
(It should be 157113 instead of 153191)"

"Invalid volume directory count
(It should be 38206 instead of 39034)"

"Invalid volume free block count
(It should be 17109528 instead of 17109526)"

Ram and video card are properly installed/seated.

DiskWarrior sounds like a great tool, but can it help me when my computer freezes during startup?

Thanks for all those that have stuck with this. I've got to figure this out sooner or later.

06-24-2003, 07:58 PM
you definately need disc warrior.
you can boot from the D War. disc( should be able to unless you have serious hardware issues ) if its the older version you have to run it under 9.(just select the X vol) works great... then hopefully you can fix and boot back into X.
if its the new version(3 ... ithink) its X native.
if the drive is toasted, disc warrior is NOT going to help( and i hope your backed up) if the super drive is not showing up, ie: wont open/doesnt mount vols. etc.
its a fair indication that a toasted drive has the whole bus "confused".
if this is the case you should be able to pull the connector from the drive
and then the superdrive should show up allowing you to boot from cd etc.
good luck

06-24-2003, 09:18 PM
This issue could be anything. I think there's a big possibility it's hardware related.

Check my previous post about bad RAM:

Sometimes it's a combination of hardware and software. For example, some hardware faults such as bad RAM can cause corruption on the hard drive, therefore creating a software problem. (So DiskWarrior is still useful in these circumstances).

Some new Macs ship with a disk called Apple Hardware Utility, which can check for problems. Sometimes a problem can still exist even though this test says it is OK.

Unplug all peripherals, including the mouse and keyboard if you can, and any network connections. See if it helps. If you still can't boot, take out all your RAM cards except one. Then try it again with a different RAM card to see if you can isolate any bad ones.

Note: If you're going to touch RAM cards, you must first discharge yourself of static electricity. Any tiny static spark can damage your good RAM cards. You can buy static wrist straps from a computer store which discharge any static from your body. Alternatively, touch some conducting metal surfaces before touching the RAM... not painted surfaces or aluminum (aluminium) surfaces that don't conduct.

06-25-2003, 07:31 PM
DiskWarrior is indeed magic. Fixed all problems quickly and easily. Wish I would have bought it sooner.

Thanks for all the advice, especially the DiskWarrior advice.

06-25-2003, 08:00 PM
DW does it again!
( I love it when things work )

06-29-2003, 01:59 AM
When your machine crashes and you can't get the CD tray to open, Toby gave the following advice earlier in this thread:

"holding down the mouse button when you turn it on is the "by-the-book" way to open the cd tray"

I'm interested if there is a "by the book" method to close the CD tray again on a frozen machine.

The only method I know of is to forcibly push the tray until it eventually closes, but on the Pioneer Superdrive (on current Macs) you have to press it very firmly before it starts closing on its own power. I'd like to know if there's a gentler method.

06-29-2003, 02:32 AM
errrr... sorry don't know that one

I thought it closed without the system anyway

(btw, I was not a tech, I just learned a few things)