PDA

View Full Version : Adding New Layer To Existing Model in Modeler-Layout



evolross
04-16-2007, 02:03 PM
Many times I have found that I need to add an additional layer to a model that I've already modeled in Modeler and animated in Layout. Whenever I add a new layer, synchronize, then switch to Layout, the new layer is not associated with the original model. It always gets added at (0, 0, 0) and as a layer at the root level of the scene. I have to end up moving it into place and parenting it to its appropriate layer in the original model in the scene.

It also seems that pivot points do not correctly synchronize if they are moved in Modeler. I understand that I can move the pivot point in Layout, but what if I realize I need to universally move that pivot point for a layer in all scenes?

Are these behaviors the standard behavior of Lightwave? I'm using 8.5. Thanks!

(Please direct to existing post if this is a duplicate.)

Surrealist.
04-16-2007, 02:47 PM
In your version of LW the most recent added item will be the last on the list. If you upgrade to 9.0 you will be able to change that. Prior to 9.0 it was fixed. That is, the order skellegons in modeler were created, as an example, and the order in which an object was loaded in to Layout determined the order it appeared on the list.

As far as the parenting goes, opening up the layers panel (F7) and double clicking on a layer name and picking a parent does not update the parenting in Layout. I know that once it is parented in layout this is a different thing, but I think it should update. However it does not.

Other than that, no parenting is assumed on an object. All layers are separate. If you want to set up initial parenting in modeler you have to do that and save it then load it into the scene as a new object then it will have the basic parenting in place.

So to work the way you are, when you create an arm for your robot (as an example) and move the pivot for the arm and then switch to layout, select the move pivot tool in layout (but don't move it) and then hit the reset button and this should put the pivot in the right location.

If you are setting up a complex object it is probably better to just do it all in modeler first, save with parenting/pivoting you've done, then load it up into a scene that has not had it before and all of the parenting and pivot data will be intact.

This feature was actually added to modeler so yo did not have to do this in a scene and then always load that object up from a scene - they way it used to be a while ago.