PDA

View Full Version : Hard FX + Collision FX = Object falls through floor



TRCC
04-13-2007, 12:13 PM
Forgive me if this is a bone-head question regarding hard and collision fx. I am trying to mimic the Creative cow logo falling and bouncing to a stop with another logo and floor object. When I set the bounce on the collision object it is way too much, but if I use the graph editor to keyframe it to 0% the object will fall through the floor at that keyframe. Im totally lost as how to keep the object from falling through the floor. Any Ideas?

Luke

Dodgy
04-14-2007, 11:20 AM
100% should mean no bounce, which doesn't make sense to me :)

TRCC
04-14-2007, 11:53 AM
Thats what I thought, at 100% I get eternal minimalist bounces.

Luke

Surrealist.
04-14-2007, 12:26 PM
Take look at this scene as a starting point. All I did was use the default settings except changed the cow to 1 piece, the gravity of the cow to -9.8 and used the floor as exclusive collision. I also set the cow to a box rather than node since all you have to do is have the feet touch.

I have no ideas about tweaking the bounce, I just figured you may have been messing with the settings and changed something. All I wanted to do was see if the general defaults would put it in the ballpark. You can compare your scene settings to this.

Let me know if this was a help at all. I really don't know much about dynamics I was just curious if I could get it to work "out of the box".

Bounce is the object file Collision is the scene.

Surrealist.
04-14-2007, 12:46 PM
And yeah, looking at it again, I remember, the eternal jitter is what I call it. You get this with cloth too.There is a setting to fix this but I can not remember what it is. I don't think graphing the bounce is the way to go though. Dodgy probably knows that setting.

Sorry for the useless scene.

Dodgy
04-14-2007, 01:20 PM
If you try Stop by stabilizer or Stop by event in the collision tab of Hardfx, that should bring things to a halt.

Surrealist.
04-14-2007, 01:43 PM
Yeah that was it. Stop by stabilizer did it here. I set it to 100% and it bounces a little then stops.