View Full Version : simple problem

04-12-2007, 11:24 AM
I am a newbie... bought the software a few months ago.
Attached is two jpegs showing that I am trying to make a simple object. I cannot get rid of the offending edge without destroying the polygon, I have been at this object for way too long. I have tried boolean, speedboolean and drill and solid drill (after extruding) and am actually getting a weird memory leak with those multipliers. I just want to make a 2d polygon with a hole in it then extrude it - everything I've tried gives me these extra lines that seem to be required for the polygon to function, the problem is that they render and ruin my output.
I know it has to be a simple fix - anybody please help?
Thank you.

04-12-2007, 01:07 PM
the edge you have, is normal...it has to be there.

now, if i understand you correctly, you want to have an object with a hole in it, and then to extrude it?

the only way that could be problematic, is if you select the object using "edge mode" and then extrude.

dont do it.

selecting nothing, or selecting the object in "polygon mode" and then extruding should work fine.

in LW, nothing selected means for LW modeller that everything is selected.

you will still be able to see the line if you are looking at the perspective viewport in wireframe mode, try changing to smooth mode (or any other mode that doesnt show the wireframe).

it should look nice and solid now....thats how it will look like in a render also.

04-12-2007, 01:29 PM
Thank you Pete for your response.
I was aware of the way to extrude the object and of the selection modes and the default of everything being selected, although none of those are obvious to a noob like me. My issue was with the extra line showing up in my render output.
I had looked at another post (you'll see I replied to it) with a similar problem and one tip there that is helping me is to triple and then subdivide - it allowed me to fix the gap that resulted and get a clean render, which is running now.
Booleans and Drills still are a problem but I think that was because I hadn't tripled or subdivided before running the boolean.
I will try to remember to update this post after my render is done and I try boolean after triple/subdivide.
Better now.

04-12-2007, 05:01 PM
If you are seeing that line in a render, then odds are you have a 2 point poly that you need to delete. Press w then in polygon mode see if any 2 point polys are listed, if they are click on the + symbol to select them and hit delete.
That line is required for a boolean subtraction to work, however some tools like the extrude tool can duplicate that line by creating a 2 point poly. It is that duplicate that gets rendered not the original line.
Hope that makes sense.

04-12-2007, 10:50 PM
Yeah and carrying forward what silk is saying. You should merge points after ALL boolean operations. You may have done a boolean and extruded before merging points and that could cause some problems.

05-05-2007, 10:25 PM
I have since learned that more symmetic modelling would have helped. I found "brute force" solution by tripling and subdividing before running a boolean operation, works every time for me, but now looking seriously at LWCAD.