View Full Version : (Another) Rigging Problem

03-26-2007, 08:08 PM
So I'm making a new thread as this is kinda a new problem and no one seems to be paying attention to my old thread where this came up.

I finailly got a rig that I was comfortable with after fighting for days with it so I decided to save it as a ur file to come back to. Well, I came back to it today and it was completely garbled, the mesh was strewn all over the bones. It looked like a bad weight map problem, or almost like every point had a different map. I turned off all maps and still nothing. Turned off bones and the mesh reverts to it's original shape, but if I turn them back on back to crazy land. Played a little but no luck. So I started over, reimported the model, converted skeligons set them up and it happened, as soon as I parented the hip to the pelvis, boom, everything goes crazy. After doing it a few times I realized it was the Record Pivot Rot. If I parented the bones before doing the record, nothing seemed to happen. But if I did it after, crazy mesh, and no amount of undoing would fix it. Did it several times and always same result. So I though "Just do it in that order..." so I did, everything was fine, but when saved that file (fine) and then reopened it, it was garbled. So then I was thinking just dont use record Pivot rot, gave that a shot. Rigged the model, everythign fine (though the gimble lock specter is very close...) but I had to split a bone for a rotation channel, yet again everything goes wonky with no fix but to start over. Has anyone else seen this? I can reproduce it over and over on both my workstaitions (believe me!) and on 9.0 and 9.2 with same result. Basically I have to tip-toe around anytign I rig and even then it's up to the fates as to weather it will come out of a save right. Please, someone help!!

Casey :cat:

03-27-2007, 01:28 AM
Select all your bones and hit the r key to rest them again. Make sure
you disable IK, expressions, match goal etc before doing so. :)