PDA

View Full Version : OGL when lighting with lum polys



druitre
03-26-2007, 10:07 AM
Maybe someone can help me out: I've been searching my brain and the forums on an issue I feel I should know. But I don't.

When lighting a scene with luminous polygons (or, for that matter, an imageworld HDR) and nothing else, I get a black OGL-view, since no lights are above 0%. It used to be (I think) that setting a light to affect nothing but OGL you could have it make the OGL-view look as you would like it, without influencing the render. That sounds logical also, to me. But I can't seem to do this; when unselecting 'affect diffuse' any OGL-affect also dissapears. And checking it, ofcourse, influences my render.

Is there some setting I've forgotten about? LW9, by the way.

Thanks,
Jasper

arsad
03-26-2007, 11:57 AM
That changed recently. To have a light that only affects OpenGL you have
to uncheck it inside of the scene editor, and yes its neither logic nor good
workflow but thats the way it is now.

Andyjaggy
03-26-2007, 01:07 PM
Yeah I ran into that problem the other day. It's dumb. Maybe they will fix it in 9.2

druitre
03-26-2007, 04:07 PM
Thanks for the answer Arsad, but I don't get it: you mean if I uncheck the light's visibility? Or that when I set the proper flags in the scene editor they behave differently than when I'd do this from the properties panel? (I'm rendering at the moment, so I can't check)

arsad
03-26-2007, 04:21 PM
http://arsad.free.fr/OGL_lights.gif

an image says more than 1000 words ;-)

druitre
03-27-2007, 03:39 AM
and yes its neither logic nor good workflow

You can say that again! Thanks for the picture,

Jasper

Yamba
03-27-2007, 05:06 AM
Thanks druitre for the question it's been annoying me for days trying to remember how get around it.

And big thanks to arsad for the answer, certainly saved a lot of wasted time seaching along the wrong path.

:beerchug: Cheers all
Yamba