PDA

View Full Version : Underwater sonic visible(invisible) pulse/shockwave. Help



chrispmott
03-23-2007, 02:31 PM
I am wanting to create a sonic pulse that is visible through a water column. It will be emitted from an object every second or so. My desire is to have it radiate out in all directions. I want it to be just visible as to not take away from the scene, but in needs to be seen enough to know it's there. Does anyone have any ideas on how to get started. I'm using v9 if it helps with vue6 xstream.

regularfry
03-24-2007, 02:44 PM
Scale a couple of transparent spheres from zero at your emitter to "big enough" at whatever you want the speed of sound to be, texture the outer with a bit of specular and a high index of refraction, and give the inner your water's IOR. Tweak the sizes and the IOR and spec of the outer sphere for effect.

Bog
03-24-2007, 05:31 PM
And don't forget your Fast Fresnel.

EagleWing
03-25-2007, 02:04 PM
what is IOR?

Bog
03-25-2007, 02:08 PM
Index Of Refraction.

EagleWing
03-25-2007, 02:17 PM
ah ha, got it, thanks bud.

Bog
03-25-2007, 02:51 PM
I live to serve ;)

chrispmott
03-27-2007, 10:16 PM
This is a repeating pulse. I set up my spheres and scaled them out and set them to repeat in the graph editor. The first image shows the repeat created without any adjustments. This makes way too many pulses. I only need 6-8 over the 500 frames. What I don't want is a slow pulse. It needs to be fast. I figured out how to stretch them out, but of course it just slows them down even more. I have been trying to get this to work all day. The second image shows the closest I could come. How do I get rid of the little hump and have it ramp up as shown? It should go fast ramp up (expansion), immediately back to zero, a bit of a pause, then repeat.

(of much less importance)
Also, on a side note, how do I move two different objects in the scene at different times? ie: one ball roles a while, then another after. If I set the first ball's key and the second ball's key and push play, of course, they would start rolling at the same time from frame zero, short of placing a key on every frame. What do I need to do?

Bog
03-28-2007, 12:41 AM
Select the keys you've drawn over in white, and set their Tension to 1.0 rather than -1.0

That should do it.

EagleWing
03-28-2007, 01:33 AM
the thing i'd do for the pulse, is to use oscilator, it's perfect for things like this, up and down/left and right/big then small, etc movement..basically, in the graph editor, select the axis to scale on, goto the Modifiers tab, then add Oscilator, double click on ocliator and scale it so you have the right about of pulses, set the start and edn frame to that in layout so you can see what it will look like.
Then once you are happy, click on OK.
you can then adjust it further by pressing "b" to bake the modifier, (note: it will also disappear).

Then to tweak further if you wished, move your timeframe over a selected point in the transparent red line you will see, and press "Ctrl + b", this will create a keyframe where you see the red line on the graph editor, you can then use these key frames much like you are doing now.
I realise creating keyframes from the footprint is much the same as manually creating them as you are doing now, but it's alsways good to learn something new if you never knew about this, also it gives you more control over wherre to create the keyframes as you then know that the keyframe you create using "Ctrl + b" will result in a smooth motion.

Hope this helps or at least has taught you something new perhaps.

Cheers,

chrispmott
03-31-2007, 04:39 PM
I would like these pulses to stay contained under the water, as my camera will be above the water's surface. Think of it being a bubble being blown up against a wall and sticking to it. I have set up dynamics but can't get it to look right. I'm hoping you can help. Here's what I have: (image shown is from a test scene I use to play with settings to try and figure it out.)

The water surface is set to collision, type: object, mode: stick.
The pulses are both set to soft, Deform/ collision detect: all, Operator/ all set to 0.
(believe me, I feel like I've tried every combination of numbers, just not the right ones yet)

This is the closest thing I can get, but it still doesn't work. First, when I calculate, it the pulses get moved up to the the surface and stretched down to the grid. Then it oscillates rapidly up and down inside itself, eventually as the pulse actually scales out larger than the water surface, it peaks through just as if the collision is not set at all. Using the operator tab I was able to get rid of the oscillation and have the pulse scale outward spherically like it should, but it is still stretched vertically and goes through the surface layer. See the image.

How do I get this to simply scale out and not go through the surface layer?