PDA

View Full Version : Need help with a possible bones problem



drclare
06-20-2003, 12:26 AM
I was setting up this character and when i finished everything was ok. Then the next day when i opened the scene file there was a very strange deformation on the characters legs. She looks like the aliens in "The Arrival". I have tried a few things to fix. I thought that maybe the morph that i applied might have done this so in the bones properties i checked "use morphed positions" but it didn't really help. When i removed the bones the character was fine. Any thought would be appreciated. I have posted an image; the first shows the dilema, the second is with "use morphed positions" checked, and the third is the way it should obviously look.

TerryFord
06-20-2003, 05:18 AM
Could be a weightmap problem, if it's not that then you could try re-resting all the bones starting from the root, you can do that quickly with BoneToggle.p, from my plugins page;

http://www.terryf.dsl.pipex.com/htm/frameplugins.shtml

Regards,
Terry

drclare
06-20-2003, 03:30 PM
Hey Terry, thanks for the help, unfortunately i can't use your plugin because i use a Mac. I did fix the problem though. It wasn't a weight map problem so i used the record rest position option for the messed up bones, however, because i used ik and the bones were in new position this didn't work quite right. So what i did was i disabled ik, then reset the rest positions of the bones, starting at the root like you said, then re-enabled ik, and now everything is fine. Thanks again.