PDA

View Full Version : IK problems with LW 7.5 scene in LW 8.3, LW9



WShawn
03-09-2007, 01:54 PM
Hi:

I have an animation using IK that I think was created in LW 7.5 that doesn't work properly in LW 8.3 or LW 9. I wasn't paying attention to that type of issue back then, so does anyone know if this was happening to other people?

I was given Lightwave Scene and Object files of a walking skeleton created in 2004. A client hired us to make some slight modifications to the animation, which was created by another animator. When I opened up the scene in LW 8.3 I got some weird stuff going on with the spine, which is controlled by full-time IK. It kind of shakes and shudders and randomly jumps to weird positions; these artifacts are not visible in the original renders of the scene. The same thing happens in LW 9.

Noticing the vintage of the scene I opened it up in LW7.5 and the animation behaved normally.

So I can make the modifications and render out a new animation in LW 7.5, but I'm curious as to why the animation doesn't work properly in later versions of Lightwave. I'm not exactly an expert in IK. Any thoughts?

Thanks.

Shawn Marshall
Marshall Arts Motion Graphics
Mac OS 10.4.7, Dual 2.5 GHz G5

Mr Big
03-09-2007, 08:34 PM
Kurv Studios has free rigging videos done by Proton. Videos 7, 8 Part 1&2,& 9 should help :beerchug:

WShawn
03-09-2007, 09:06 PM
Hi:

Thanks for the reply. I've looked at some of those videos, and I'm actually in the process of buying some of Kurv's rigging and character animation videos.

The problem isn't the rigging. The rig and animation works fine in LW 7.5. The problem is when you open that scene in LW 8.3 or LW 9 the animation goes a little haywire. The IK chain of the spine jerks around and shudders. I'm guessing Newtek changed the code for IK which isn't entirely compatible with LW 7.5 animations. This isn't a big deal, since I have LW 7.5, but I'm curious to know whether other users had similar issues.

Shawn Marshall
Marshall Arts Motion Graphics

evenflcw
03-10-2007, 07:22 PM
Could you perhaps crop out the spine and upload the scene?

Things to check for:
-That IK chains are terminated properly.
-That the rig isn't too far from the origin (0,0,0 in world space). The IK solver seems to loose accuracy when it has to juggle big numbers.

You could also try fiddling with the IK setting in hidden features mode... press ctrl+shift+F1, then ctrl+alt+F3. I've used it successfully once, but don't ask me what the numbers stand for :)

evenflcw
03-10-2007, 07:23 PM
double post, sorry

WShawn
03-12-2007, 12:34 AM
Thanks for the reply.

I'll can play around with the IK settings at some point. But still, my primary question is why this IK set up works fine in LW 7.5 but the exact same scene whacks out in later versions of the program. Did NT rewrite the IK section of the program when they went to LW8? Did anybody else experience this problem?

Shawn Marshall
Marshall Arts Motion Graphics

adamredwoods
03-13-2007, 01:28 PM
If there's a goal null, try turning off the IK setting 'Keep Goal within Reach' and then experiment with the 'goal strength' setting (set it to 10.0 or 100.0) to get rid of the shuddering.

Usually shuddering means IK is having a hard time solving to your goal. Another prolbem could be if there's a motion modifier plugin, or even expressions, on one of the bones the original animator used. That could cause issues from version to version.

WShawn
03-14-2007, 01:12 PM
Thanks for the reply. I'll try playing with those settings.

Shawn Marshall
Marshall Arts Motion Graphics

WShawn
03-14-2007, 06:39 PM
Hi:

I found the culprit. The spine on this skeleton model is made up of 47 layers. In the original LW 7.5 scene the heading, pitch, and bank of each spine object was controlled by IK. For some reason, when opening the scene in LW 8.3 or higher, the pitch channel of all the spine layers is set to be controlled by keyframes. Heading and bank are still set to IK. So I opened up the property tab in the Scene editor and set it to Motion: Controllers and Limits: Pitch and selected each one of the 47 spine elements and set the Pitch Controller of each one to Inverse Kinematics. Once I did that the spine behaved itself: no shuddering or jerking around.

Which brings me to another question/gripe. Shouldn't there be a way to shift-select all of the contiguous bones, change the popup to IK, and have them ALL change? Even when they're all selected, changing the popup only changes the setting on the single item I've clicked. This inability to make global-ish changes has annoyed me for a long time.

Thanks.

Shawn Marshall
Marshall Arts Motion Graphics

evenflcw
03-15-2007, 02:35 AM
Shouldn't there be a way to shift-select all of the contiguous bones, change the popup to IK, and have them ALL change? Even when they're all selected, changing the popup only changes the setting on the single item I've clicked. This inability to make global-ish changes has annoyed me for a long time.

This should already be possible (since sometime in the 7.x cycle I think). Ie you should be able to select multiple bones (contiguous or not) and change the rotation controllers and it should update for all selected bones. Mind you, not all item settings support multiple selection like this, but this does. If it still doesn't work try the Spreadsheet or the Property tab in the new Scene Editor.

WShawn
03-15-2007, 02:48 AM
This should already be possible (since sometime in the 7.x cycle I think). Ie you should be able to select multiple bones (contiguous or not) and change the rotation controllers and it should update for all selected bones. Mind you, not all item settings support multiple selection like this, but this does. If it still doesn't work try the Spreadsheet or the Property tab in the new Scene Editor.

Umm, as I said in my previous post:


I opened up the property tab in the Scene editor and set it to Motion: Controllers and Limits: Pitch and selected each one of the 47 spine elements and set the Pitch Controller of each one to Inverse Kinematics...

I've tried selecting multiple items using the Property tab in the Scene editor. Even though multiple items are selected, the only one that changes is the one you click on. You have to click on every individual item to change them all. This is lame.

Shawn Marshall
Marshall Arts Motion Graphics

Dodgy
03-15-2007, 04:17 AM
You can multi select the bones/items and set the all in the motion panel in one go.

If you are using the scene editor, did you multi select the items or the IK fields? You have to click/shift click in the little column next to the field you want to change and little numbers should appear. then you should be able to change it for all items. Not the most intuitive UI design in LW :thumbsdow

evenflcw
03-15-2007, 04:21 AM
Ah, sorry for not reading through your post well enough.

The property tab in the new Scene Editor doesn't work like this (unfortunately). You should not be selecting items, you should be selecting cells. To select multiple cells you should be shift or ctrl clicking the socalled Selection Zone, which is a thin strip to the right of every cell.

WShawn
03-15-2007, 04:12 PM
Hey, that does the trick! It obviously never occurred to me to click in that little side strip (to the left, actually), and I didn't think to check the manual for that type of interface thing. This should simplify a lot of things for me in the future.

Thank you for the info.

Shawn Marshall
Marshall Arts Motion Graphics