PDA

View Full Version : Is a purple Rainbow SuperPro Mac compatible?



ELinder
02-24-2007, 03:21 PM
I'm a long time Windows user with a new MacbookPro, and I'm trying to install LW9 on the laptop. My dongle is a purple Rainbow SuperPro usb dongle from the LW7 days. Is it a windows only dongle? OSX shows it only as a USB token, the registration program can't find it, and in Layout it says dongle ID:0. I've talked to NewTek, and 1 person says I should be able to use it, and another says no. I used the newest driver from the SafeNet website, and checked that EVE3 framework was installed. Is the problem a Mac/Intel one, or do I need to exchange this dongle for a new one with the same lock ID so my Windows plugins still work? Thanks.

Chilton
02-24-2007, 03:40 PM
Hi,

I'll have to ask. Fortunately, the people I need to ask will all be around tonight, so I will have an answer for you tomorrow. The only issue *I* am aware of is that we shipped an Eve3 Dongle that was Mac only. The PC ones should work. However, we also did a lot of work on the dongle system for the Intel version. So my results might not be your results.

-Chilton

ELinder
02-24-2007, 06:01 PM
They'll all be around tonight? On a Saturday night? Thanks for looking into it for me, but jeez, do you guys live at work?

I noted that at the SafeNet website, the Mac dongle drivers are from last year, and there's no mention of them being UB. Could that be part of the problem?

Erich

Chilton
02-24-2007, 06:13 PM
Hi,

No, that only becomes an issue with the Universal Binary of the host application, in this case LightWave. And that's something we've already addressed in the UB version.

You need the CFM version for now, which is what you've installed.

-Chilton

Chilton
02-25-2007, 02:04 AM
Sorry, forgot to ask. I'll ask around tomorrow though.

-Chilton

JohnKocon
02-26-2007, 10:21 AM
I hope you don't mind if I jumping on the LW9 Rainbow SuperPro USB dongle not recognized bandwagon with you-

-for 2 reasons-

my MacBook Pro has yet to recognize the dongle- but even more troublesome is that I had LW9 running on my PowerPC G5, but after a crash forced me to reinstall OS X (10.4.8), I was unable to get LW to see my dongle on that machine anymore- even after a fresh reinstall of LW9 -fortunately the dongle still works on my MUCH slower G4 - so I haven't missed any deadlines, yet. Must get faster machine back online ASAP though.....

ELinder
02-27-2007, 06:08 AM
That's wierd given that it worked before on the same machine. Until I get this resolved, I'm running LW under bootcamp, but I'm surprised how much as a long time Windows user I'm beginning to really dislike having to boot up XP. I think my conversion to Macland has taken root. (looked for a smilie dressed like an apple but couldn't find one) :)

Erich

Chilton
02-27-2007, 06:28 AM
Hi,

I asked. Regarding the purple PC-only dongle, we never actually shipped a PC-only one, but there was a period where the drivers weren't working on the Mac version, at one point before I came here. So I have no firsthand recollection of this, but several of the other developers are pretty sure that happened. It's resolved now, and those dongles should work on the Mac now. And they will of course work with the Universal Binary.

-Chilton

ELinder
02-27-2007, 06:50 AM
So it should be working with the PPC version on a MBP (the Core2Duo one, not the original CoreDuo one)? It sounds like more changes were made to the UB version dongle handling, so it would be more likely to work? I've also tried the PPC beta of LW 9.2,also no luck. Of course, if you need the UB version tested on another machine for compatibility, I'm willing. :D Seriously.

Erich

ELinder
03-01-2007, 06:59 PM
Chilton,

Since it should be working, who should I ask for when I call Newtek next time to help me get LW9 running on my MBP?

Erich

Chilton
03-05-2007, 11:46 AM
Chilton,

Since it should be working, who should I ask for when I call Newtek next time to help me get LW9 running on my MBP?

Erich

Check thine private messages... :D

-Chilton