PDA

View Full Version : Rendering outlines-- LW9 question



medicalart
02-22-2007, 07:55 PM
Is there a way to render a Lightwave scene (Render Frame) so that it matches the textured, shaded, solid wireframe view? When I select "Render Outlines" (Advanced tab of the surface editor), the surfaced polygons disappear, and only the mesh remains. I tried superimposing identical objects--one with mesh and one without--but it doesn't render properly.

If there is a way to do this, then I have a part 2 of the question:
Is there a way to show only the outline of the object without any of the interior mesh?

Any ideas? Thanks.

Silkrooster
02-22-2007, 09:19 PM
Instead of doing that in the surface editor, use the objects properties and enable rendering of edges there. This will allow you to see the edges and the surface at the same time.
Silk

Surrealist.
02-22-2007, 09:56 PM
This just came up.

This thread has a link to a plugin

http://www.newtek.com/forums/showthread.php?t=64036

BTW, silk, do you remember that thread a while ago, where people were trying to figure this out to render wireframes? I seem to remember that there was another plugin.

Silkrooster
02-23-2007, 02:06 AM
The only other plugin I can think of at the moment is Truss 2.
Silk

medicalart
02-23-2007, 08:30 AM
The sub-patched surface mesh obscures the object. Without sub-patch, the mesh is faceted. So far I can't find a happy medium.
As you said, object properties is the place to set things--and I realized I had the outline color set to black so I couldn't see the outlines.
Thanks.

SP00
02-23-2007, 08:38 AM
Would there be a way to keep everything in quads when the image is rendered out? Everything is triangulated.

Surrealist.
02-23-2007, 09:08 AM
The sub-patched surface mesh obscures the object. Without sub-patch, the mesh is faceted. So far I can't find a happy medium.
As you said, object properties is the place to set things--and I realized I had the outline color set to black so I couldn't see the outlines.
Thanks.


That plugin will allow you to assign surfaces for every other polygon like a checkerboard pattern - it does it automatically and quick - then you use the edge surface lines option. Basically it will allow you to subpatch and have the original polylines rendered. You have to have a copy of your object as it will overwrite the surface info for that.

I think the plugin silk found may alow you to keep the surface data - not sure.

medicalart
02-25-2007, 09:46 AM
I just noticed that the manual discusses the problem and offers a solution:


Edge Z Scale

When pixels of a polygon edge are rendered, they will have depths that are approximately equal to those of the polygon that they belong to. This means that some of the pixels will be visible while others will be hidden, which could result in broken-looking edges.

To prevent this, LightWave multiplies polygon-edge depth (i.e. Z buffer) values by a scaling factor, the Edge Z Scale, which is, by default, slightly less than one to ensure that the edges are always drawn on top of their polygons.

The default value, .998, should work in nearly all cases. However, in certain circumstances, like camera zoom factors that are extremely high, you may need to adjust this value. However, if the value is too high (i.e., too close to 1.0), the edges start to submerge into the polygon and break up. On the other hand, if the scale factor is too low, the edges will come in toward the camera too much and may even start to appear in front of other polygons that they should be behind. If either of these problems occurs, adjust the Z scale in the appropriate direction; otherwise, leave it alone.