View Full Version : Grave and Deeply Troubling bones issue

02-19-2007, 04:28 PM
I found a repeatable and serious issue with bones. I really hope I'm simply doing something wrong, and the issue isn't Lightwave.

I've modeled crab like animal, drew Skelegons in Modeler, made weightmaps, all of which are perfect for my needs and do their thing correctly. With a couple exceptions, all the joints in my rig (that I've set up so far) work right.

The couple exceptions are corresponding joints on one pair of limbs.
I used bone twist to get the angle of some of of the joints' bending axis to be correct. It is on one side. Getting the other side to correctly mirror the first (correct) side is proving impossible with the mirror function built into the Bone Tools.

Having had this problem before, I found that one solution is to manually draw a bone and parent the child of the bone whose angle I couldn't fix to it, basically forcing a desirable joint on the situation. This has worked *perfectly* for a couple joints in other limbs, before so I still use this method.
I have parent in place turned on when I do this.

Trouble is, just like the bones tools, this method has ceased to work as well.
When I re-parent, the bones stay in place, have the same hpb, etc, but their influence is all wrong. It is as if the mesh is displaced in one direction down on the y-axis away from the bones. Yet the bone that gets re-parented appears to be in the correct place.

I tried it several times, all with no luck. Its repeatable. I'm wondering if there is something I can do at the scenes' code level, where I can find the line of code corresponding to the joint in question and force it to work properly by coding it. Or find the code fof the one that works properly, and finding out how to properly define its mirror through code.

Hopefully someone else has found a solution and knows an answer.

Thanks in advance!

02-19-2007, 05:27 PM
Wasn't obvious (to me, anyway):

Actual position and rest position differ by a very small value: -.0001 in every case. Solution was to select the bone that had been re-parented open bone properties, hit rest position button. The actual position value in the lower left of the LW interface and the rest position were almost the same, but didn't match. Copying the value from the actual position to the rest position field did the trick.

Thanks to DaveW over at cgtalk, for his suggestion.

Glad it was user error.