PDA

View Full Version : Smoothing help?



familyguyman
02-07-2007, 10:32 PM
Let's say I'm modeling a martini glass, and when I render, I can still see the individual sides of the glass, even though I've turned on smoothing in the surface editor. Is there anything else I can do to smooth those sides? Does it have anything to do with the smoothing threshold? If so, how do I know what to set it to?

Silkrooster
02-07-2007, 10:39 PM
Its possible you have doubled polys one laying on top of the other, or there are 2 point polys on the edges. Things to try,
1) press m key to merge points, Select detail>polygons>more>unify polys.
2) press w key, press ctrl-h, scroll window down to 2 vertices if not greyed out click on + before it then press delete key, Also if 1 vertex is not greyed out delete them as well.
If this still does not help let us know and post an image of the render glass with a screen grab of surface settings.
Silk

familyguyman
02-07-2007, 11:01 PM
Here's the render with the surface settings. I'm using the glass preset, the outside polygons one. I tried those other things and they didn't work.

Silkrooster
02-07-2007, 11:23 PM
The smoothing threshold should not have to go over 90 degrees. The default is 89.53, there are times when this should be lower to help remove smoothing errors, but I can't think of any time when it should be higher, though I am sure someone has had to. lol.
Turn off double side polys, that may be whats giving you the problems. Your object is transparent and it is trying to render both sides of the poly. If you need two sides, you are better off copy, pasting and fliping the polys, seams to have fewer render errors. I have yet to use the double sided option in the surface editor, as I have heard of way too many render errors caused by it.
Silk

Anti-Distinctly
02-08-2007, 01:14 AM
I would suggest the same. In modeller, make sure points are merged, then copy your polys, paste, then press f for flip, then give those polys the name 'air polys'.
You also need to set up fresnel reflection to make your glass look correct.
With your glass surface, click the texture button on the 'reflection' channel, then set it to 'gradient' and set the input to 'incidence angle'. Put a key on the gradient at 0, with a value of about 5, then create another key at 90 with a value of about 90.
Copy this texture layer, then click the texture next to 'transparancy' channel, paste it in then click 'invert'.
Set the refraction index to 1.5 or whatever glass is.
Set the diffuse to something like 10% and make the surface colour black or very dark.
Also make sure you have an environment texture set up to reflect or you wont see anything (I just use Image World)
With the air polys, set the tranparancy to 100%, refraction index to 1.0, colour to black, diffuse to 0.

I know most of that's not exactly what you were asking for, but you can do nice glass now :)

prospector
02-08-2007, 03:03 AM
It looks like there are polys between the outside and inside surfaces.
Hard to tell without closeup.
so I would try to be in poly mode, lasso the poly edges from rim to stem (same direction as the wierdness is showing up), if a line highlites then delete it.
If there are any then they will be quad polys and not show anything is up in info panel and be listed with other quads.

Dave Jerrard
02-08-2007, 10:39 AM
Looks like non-planar polygons to me. The light leaking through them in the shadow is usually the giveaway.

Try tripling the polygons. This should clear up the issue.


He Who Learnt That Trick Way Back In LightWave 2 And Hasn't Forgotten It.