PDA

View Full Version : render twinkel



Jerembass
02-04-2007, 05:20 AM
ok this has probly already been asked but i couldn't find a thread on it... when i render a model i have that has a very high detailed image mapped on i get this twinkeling in the animation... i had it on a 9 pass AA and the only way i got it to go away was to use the soft filter but i want the oject and the image map to be sharp and with high detail... can someone please guide me... thanks

Bog
02-04-2007, 05:28 AM
Have you tried disabling mipmapping and pixel blending in the textures panel?

Are you using Adaptive Sampling?

Jerembass
02-04-2007, 05:55 AM
this is the lastest setting ...
Antialiasing: classic,enhanced med..
reconstruction : gaussian
Adaptive : 0.15
still a little twinkel

Bog
02-04-2007, 07:49 AM
Try switching Adaptive Sampling off completely if you're using 9.0 or below.

toby
02-04-2007, 03:44 PM
This is exactly what High and Extreme anti-aliasing is for. Don't be afraid to turn it up, it may take longer, but you'll have fewer re-renders like this, and higher quality every time. I never use Medium except for test renders. Gaussian won't help you, and slows down the render - classic is still the best filter. Adaptive sampling off, mip-mapping and pixel blending on.

JamesCurtis
02-04-2007, 06:00 PM
I also very rarely use Soft Filter setting in Camera properties because it softens too miuch. Supposed to look like film but just looks way too soft for it. I wish that NT could come up with a variable level method for it.

toby
02-04-2007, 10:13 PM
Better not to do any blurs in the render, do it in post, then you can always go back.

Bog
02-05-2007, 02:48 AM
Better not to do any blurs in the render, do it in post, then you can always go back.

Not "softening" blurs, certainly. Ick. Motion blur, DOF blur and the like are best handled in the render.

Not implying that Toby's in error here, just "notes for the n00bs" if you would.

starbase1
02-05-2007, 03:10 AM
Sounds like you might need to take a look at that model. It's always going to be messy if you have high contrast sub pixel details in a moving object - what happend basically is that you don't get a consistent average colour with the anti alias sub sampling.

This gets very painful - statistically speaking you typically need to quadruple the number of passes to get half the flicker.

If the model uses images maps, you may want to try shrinking them and/ or blurring them a little, at least for more distant shots.

A very handy trick that seems less well known, is to use the wavefilter image processing filter - In particular the option to soften sharp edges. I generally find a tolerance of about 80% and 4 passes works well.

One advantage of this is that if you have been writing out as image sequences, you can load them in as a backdrop and run the filter over them VERY quickly! Handy for experimenting with settings, without having to rerender the whole lot every time...

Nick

toby
02-05-2007, 09:31 PM
Not "softening" blurs, certainly. Ick. Motion blur, DOF blur and the like are best handled in the render.

Not implying that Toby's in error here, just "notes for the n00bs" if you would.
Yes, that's what I meant - thanks for clarifying :o

Bog
02-06-2007, 04:41 AM
I'm just showing off, really ;)

toby
02-06-2007, 09:36 PM
I'm just showing off, really ;)
Why do you think I have so many posts? :rock: