View Full Version : DVD Workshop and MCMPGDEC.DLL error

02-19-2003, 12:04 PM
Do any of you have Ulead DVD Workshop and Toaster on the same machine? I used to, but since upgrading to XP I'm having a problem. If I install DVD Workshop, Toaster will give me an Ordinal Reference error on the file MCMpgDec.dll. When I look on my machine, I see that file under two different programs: DVD Workshop and Sonic Foundry. I believe under my previous install I simply replaced the DVDWorkshop one with the Sonic Foundry one (different sizes/dates) and things worked. However, this is not working now. If I rename the file, then DVD Workshop does not work.

Any ideas?


02-19-2003, 01:52 PM
We don't have Toaster and DVD workshop on a WinXP machine, but it is working fine on our other 2 Win2k machines.

How fresh is your install?
I would suspect that the problem is ULead related. I have not been real happy with their progress on the DVD workshop product.

Sorry couldn't be of much more help.

02-19-2003, 04:49 PM
Actually, Toaster runs GREAT under XP and I would recommend it.

I was able to fix it. I got the codec .dll from Sonic Foundry (a new one) and replaced the ULEAD one and now things work fine.

Thanks for your help!


02-19-2003, 08:49 PM
Hey Grimps,
I have been working on setting up a new Toaster XP. I have DVD Workshop and it has run fine on a win2k install. Sounds like I will have this problem when I go to put workshop on the xp system. I do not use Sonic Foundry though. Where do I go to get the updated dll file?

02-19-2003, 08:54 PM
Well, I tried to attach it, but it won't let me. Send me your e-mail address and I'll e-mail it to you.

I don't know that it's XP related really, maybe just something with install order.


12-22-2004, 01:29 PM
could you email the dll to mike at vg-productions dot com

Keith Nealy
01-05-2005, 05:34 PM
If its not a problem Phil, I'd like a copy of that also.

Or at least the date and file size so I can check it against mine.




keithn at aloha dot net

01-28-2005, 01:05 PM
Phil, or someone,
Would you be so kind as to send this improved .dll my way. I'm having the Ordinal error boxes popping up constantly.

Need a fix asap.
Many thanks, DonN

01-28-2005, 01:08 PM
:p :p :p

DonN is djnelsonxx at starband dot net

Thanks again

10-15-2006, 04:17 PM
I am having similar issues

I could use a better version of the Mcmpgdec.dll
I think? Send it my way [email protected] dot com

mcmpgdec.dll I found one and that is 529 k created 4/7/2003

the other is 528 k and created 10/13/2006
the older one was in Cleaner Xl the newer in ulead DVD workshop

should there be a Mcmpgdec.dll in the VT4 somewhere as well?
If I put duplicate dll's in their respective directories do I use the newest one?

I could use some advice have a contest entry that is getting close to the deadline.

I just installed VT4 4.6 on my Xp duel xeon I upgraded from VT3