PDA

View Full Version : Can't nulls to act as goals in a boned character?



DonAVP
01-27-2007, 12:06 PM
I am trying to rig a character. I have created four goals for the left and right feet and arms. When I convert the skelgons into bones and select the Right-leg-goal for the right foot bone in the motion panel (for example) it does not follow the goal when I move it around. I have all of the IK buttons select to activate the chain. I know I am missing something really simple. Don't do it enough the remember all the steps. The bones are working and the mesh does react to any movement/rotation I do. BTW I have another character (a man) that is working and use it to try and figure out this but have not.

Thanks in advance

Don

spec24
01-27-2007, 12:56 PM
My first thought is that you don't have one extra bone attached to the end of your bones you want reaching for the goals. Remeber that the origin of the bone is what will try to reach for the goal, so to use IK effectively you will need one extra bone at the very tip of the last bone in your chain (just a tiny one) to actually do the reaching. This is a real pain that I hope Newtek will address.

Also - do you have Enable IK and Enable Deform turned on in the setup panel?

Dodgy
01-27-2007, 01:05 PM
Have a look at my plugin page for some useful plugins, including an autoIK script.

You need to:

A>set the null as a Goal in the end bone's IK goal option in the motion options.
B> set it's parent/ancestors channel Controllera to IK
C>Terminate the IK chain by setting 'Unaffected by IK' on the parent of the root bone.
D> ensure IK is enabled by pressing shift F8 if it doesn't seem to be doing anything...

Surrealist.
01-27-2007, 01:19 PM
Make sure and set the goal strength something other than 1 (40-80 is a good range to play with - and that the end bone has been assigned to that goal object of course) and that you have the rotations of the bones set to inverse kinematics on the controlers and limites tab of the motion options pannel. You must have at least one rotation on each bone in the chain set to IK.

EDIT: We responded at the same time.

DonAVP
01-27-2007, 04:10 PM
Have a look at my plugin page for some useful plugins, including an autoIK script.

You need to:

A>set the null as a Goal in the end bone's IK goal option in the motion options.
B> set it's parent/ancestors channel Controllera to IK
C>Terminate the IK chain by setting 'Unaffected by IK' on the parent of the root bone.
D> ensure IK is enabled by pressing shift F8 if it doesn't seem to be doing anything...

Thanks for all the suggestions.

DODGY I went to your sight and I will download the AutoIK script. This could be useful when I need to do the again in the future and can't remember all of the steps.

I asked this on other forums and I think I got the answer. I need to active IK in one or all of the channels on the other panel in the motion popup. I will do this Monday.

Don